[Samba] Unmountable Linux Samba mounts

Z Linux zlinux2002 at yahoo.com
Wed Jul 31 23:16:04 GMT 2002

I get the same problem when I mount smb shares and
then disconnect my notebook from network without
unmounting the share, it seems like samba needs the
share to be available to unmount it, however for me, I
 umount -l /your/mountpoint
this will free up the mountpoint and will try to fully
umount in the backgroud (I guess). Not a very
intelligent solution though because I still see
smbmount in the process list, it will atleast free up
the mount point.

--- Rob Gillen <borgille at pobox.com> wrote:
> Some of you might be familiar with the strange way
> that Linux will
> sometimes disallow umount-ing or listing directory
> contents of a mounted
> smb share, returning the error text, "Input/output
> error."  I believe
> this error happens when a smb share is mounted, then
> that remote share
> is removed.  This is a seriously annoying problem,
> because restarting
> Samba does not solve the problem, nor does changing
> runlevels.  I am
> guessing that it may be a kernel-level problem, so I
> am looking for more
> information and possibly some confirmation on this. 
> I have tried
> changing the runlevel to [S]ingle level user, which
> is running pretty
> much nothing save kernel processes and a simple
> shell. At this level, a
> 'mount' command still shows the shares to be
> mounted, and also at this
> level it is still impossible to umount them.  The
> only solution that I
> have found so far is rebooting, which I think is an
> unacceptable way to
> handle such a problem.
> On a possibly related side note, during the time
> that I could not remove
> the unmountable mounted smb shares, the dhcpd daemon
> that was running on
> the box also seemed to start malfunctioning.  On the
> Linux box
> (Mandrake), everything appeared to be fine; that is,
> I was able to
> restart the dhcpd daemon without any errors.  But
> none of the other
> networked machines which normally get served
> addresses from it were
> getting addresses.  Unfortunately, I wasn't able to
> sniff packets, so I
> don't know what kind of communication (or lack
> thereof) was occurring,
> but it did seem like network traffic was being
> blocked in the Linux box
> from something.  It was a frustrating exercise
> trying to figure out why
> my other boxes were not getting addresses. 
> Strangely enough, after I
> rebooted the Mandrake box, everything worked as
> normal again, and the
> other boxes got their IP addresses fine.
> Like I said, I don't know for sure if the dhcpd
> thing was related to the
> smb mount problem, but I'll try to repeat the
> problem when I get some
> time and see if it recurs.  If anybody has seen the
> same problem or
> something similar, I would appreciate it if you
> could share how you
> resolved it.  As I also said, this might be strictly
> a Linux related
> problem.  I don't have any other platforms to test
> it out on.
> Thanks,
> Rob
> -- 
> To unsubscribe from this list go to the following
> URL and read the
> instructions: 

Do You Yahoo!?
Yahoo! Health - Feel better, live better

More information about the samba mailing list