[Samba] w2k-no longer trusted (plse help!)

mlb mbruntel_nospam at comcast.net
Wed Jul 31 13:56:03 GMT 2002

Please help me?!  I am at my wits end.

Or is it:
a twisty maze of little passages  : N
a little maze of twisty passages  : N
but I keep missing my batteries!  <and my lantern is going dim...>

[sorry for the OLD reference!]

Was:  Help-w2k pro no longer "trusted" in 2.2.3 pdc
------------------Here is the pre-amble and request?!----------------
    Here's my story...sad but true.
  I've got a run-away PDC, that makes me blue.

  It don't see my NT-clients nice anymore,
  now it says, "get offa my Floor"

  And I'm in the doghouse so I'm writing you
  so that I don't kicked out,and get black and blue

------------------Here is the problem----------------
I have several W2k Workstations, with a SAMBA 2.2.3 PDC.

Problem is that I must have removed all of the important parts of the
 server validation.
OUTLAND is domain, W2k/ clients are milo  and lola.
They WERE working fine on the domain.  I did SOMETHING (??)
 and now I get a message that says (when I try and log on: The system cannot
 log you  on to this domain because the system computer account in its
 primary  domain is missing or the password on that account is incorrect.

now:  I tried to delete the machine accounts (milo$ and lola$)
   using userdel and smbpasswd -x to eliminate all traces.

Tried to change out of domain, changed machine name, log
 in: still no   good, same messages.
Then I tried the same thing, but this time also deleted the
secrets.tdb file.  Then did a smbpasswd to add  the root account

STILL same problem

HELP!  I have no idea what to do!

The last thing I tried was to to change the machine name
 and out of the  outland domain.

     So I tried to change the name of the client to stevedallas,
 and the workgroup to temp
     That change worked ok.  After this, I logged in, ok (as admin),
 and was  then able to change back to outland domain.

Now I was able to log in as workstation/administator
and I added new user/browse and it did see the outland domain.

I click my outland domain name, and next and the the message:

The user could not be added because the following error
 has  occurred.
     The trust relationship between this workstation and the primary
 domain failed.

     SO I am stuck without getting any user logins (at least I
 can login as admin...

     please point me in the right direction??? thanks

More information about the samba mailing list