[Samba] Printing:using usb port.

Trevor Fraser trevor at systematic.co.za
Tue Jul 30 02:33:02 GMT 2002

Hello All.

Thanks for the help so far.  I've managed to get the 'access denied' error to disappear with the suggestion of 'use client driver = yes'. This worked, Thanks.

By the way, I'm running Samba 2.2.3a

I'm still not printing though.  I removed the printers I configured using 'printconf-tui' and added a new local printer device, using /dev/usb.  This was to narrow down the problem to between the Red Hat Linux Server and the printer.  The printer is a HP OficeJet K80 series, and the package has reference to it and a suitable driver, namely hpijs.
I think the problem lies with the usb port.  I installed the PCI 2 PORT USB 1.1 CARD for our UPS, but we've always used the serial port as it works, so I have never figured out how to mount and use the port.  My lsmod produces the list: 
MODULE                            SIZE        USED BY        NOT TAINTED
st                                      28820              0                      (unused)
ide-scsi                                9312             0            
scsi_mod                         103904             2                   [ st ide-scsi ]
parport_pc                        17988              1                    (autoclean)
lp                                        9024               0                    (autoclean)
parport                              33280              1                     (autoclean) [ parport_pc lp ]    
autofs                                11940               0                    (autoclean) (unused)
3c59x                                27432              1
ide-cd                                29856              0                    (autoclean)  
cdrom                                33184              0                     (autoclean) [ ide-tape ]
printer                                8640                0                                
usb-ohci                            20160               0                    (unused)
usb-uhci                            23492               0                    (unused)
usbcore                             71168               1                    (printer usb-ohci usb-uhci)
ext 3                                  64448               5
jbd                                     47608               5                    [ ext 3 ]

Also noted, the only device related to usb in /dev, was /dev/usb , thats the only reason I used it in the printconf-tui.  What am I missing, docs I'm not reading or other naughty/lazy things I'm doing/ not doing?  Please advise.   

Thanks, Chow,
  ----- Original Message ----- 
  From: Trevor Fraser 
  To: samba at lists.samba.org 
  Sent: Monday, July 29, 2002 8:55 PM
  Subject: [Samba] Printing:access denied.

  Hello All.

  I'm using Windows 2000 prof on a NT domain with samba as the PDC.  The printer is connected to the samba server via a usb port.

  I've tried all that seemed obvious to me, and still the same message.
  Ive made the printer share directory belong to root and group owner every, which has everybody who should print belonging to that group and chmod 770.  I've made the printer$ share guest ok, assigned a valid account as a guest account, and even added everyone to the printer admin list.  What else could give "access denied" error?  

  Thanks, Trevor.
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list