[Samba] weird printing with samba 2.2.4 problems under FreeBSD 4.6-STABLE

davoid at softhome.net davoid at softhome.net
Mon Jul 15 11:41:44 GMT 2002


I have a simple samba 2.2.4 setup here under FreeBSD 4.6-STABLE: I want to 
share my printer through samba to other windows clients on my LAN. I already 
have this working perfectly under Linux on the same machine, however the 
freebsd port or package seem to not work. 

 - the printer is correctly set up with LPRng (lpr <file> prints file 
correctly). However when I connect to the share with smbclient 
\\\\Storm\\Cannon_Linux -U davoid, I supply my password and put a file, it 
doesn't get printed out! nor does it appear in /var/spoo/samba. Permissions 
of /var/spool/samba seem correct. Everybody can read, write, execute 
/var/spool/samba. Note that the same operation under Linux works. I have 
even tried using the same smb.conf under fbsd as under Linux. Still can't 
print! Here's my current smb.conf 

# Samba config file created using SWAT
# from Storm (
# Date: 2002/07/15 11:12:25 

# Global parameters
workgroup = IAAI
netbios name = STORM
server string = davoid's samba server
encrypt passwords = Yes
printing = lprng 

comment = Canon BJC-210
path = /var/spool/samba/
read only = No
guest ok = Yes
printable = Yes
printer name = Cannon_Linux
oplocks = No

Please note that the share name Cannon_Linux is only due to the fact that 
the same printer under Linux on the same server is named Cannon_Linux and as 
to not have to reconfigure windows clients I named it the same. 

Samba is running from inetd, and is running well. I can share a folder and 
it works perfectly. Only printing is a problem. 

Note: I have tried both the package 2.2.4 and the port, the same result. I 
have even tried printing from the windows clients, I cannot. 

I have had the same problem a whole ago and been unable to solve it... I am 
really looking forward for any help/tips. And yes, I have read the manual 
pages, using samba over and over.. 


More information about the samba mailing list