[Samba] Setting file permissions through SAMBA

C.J. Keist cjay at engr.colostate.edu
Tue Jul 9 12:27:04 GMT 2002

No, this should not be a problem.  When running a mixed environment of UNIX 
clients and Windows.  Windows client simply use the shares on our UNIX file 
server via SAMBA, and UNIX clients continue to mount via NFS as 
usual.  SAMBA seems to be missing a step when it changes permissions on the 
file.  Local on the file server everything is fine, but UNIX clients 
accessing via NFS don't seem to get updated that the permissions on the 
file have actually changed.  The nfs clients show the correct permissions 
using "ls -l", but it doesn't behave as what the permissions show.  So when 
I set the read access for Everyone through SAMBA, it shows the read access 
for everyone on the client nfs, but will not let you view the file 
still.  Only after doing a "chmod", then it allows you access to the file.

At 11:54 AM 7/8/2002 -0600, John Benedetto wrote:
>I thought you were NOT supposed to access a filesystem via two different 
>methods... (someone correct me if I am wrong)...
>So... can you have the web server access the filesystem through smbmount 
>rather than the NFS it is currently useing ('smbmount' may not be the 
>correct term I am looking for...  whatever would be the correct 'Samba' 
>method - I may be using the wrong term, since I have never tried to have a 
>Un*x box mount my Samba space).
>- john
>--On Monday, July 08, 2002 11:20 AM -0600 "C.J. Keist" 
><cjay at engr.colostate.edu> wrote:
>>I've tried the samba lists but have not gotten any response for my
>>problem.  This looks to be a bug.   All our user files are accessed
>>through SAMBA on our main file servers, one is Linux RH7.2 and the second
>>one is a Solaris system running Solaris 8.  The problem we're seeing is
>>that when some one creates a file for their web page, they have to set
>>the permission on the file to rw for owner and r for group and Everyone.
>>When you look at the file in UNIX it does show the correct permissions,
>>but the Web server says it cannot access the file.  The web server
>>accesses user's personnel web pages via NFS.  The file shows  the correct
>>permission on the Web server too.  The only way to get the web server
>>(Apache) to access their page is to do a "chmod 644" in UNIX again.
>>After that the apache web server can access their files. So it looks like
>>SAMBA is changing the permission on the files, but is missing a step
>>somewhere.  Like its not sending a signal or something to notify the
>>system that the file permissions have changed. This is not an Apache
>>problem as I can "su" to the apache user (or any other user) and not be
>>able to 'more' the file.  Even though it has read permission for
>>everyone.  This looks to be a problem where the files are accessed via
>>NFS.  Changing permissions on files local to the web server works fine.
>>SAMBA version: 2.2.4 and 2.2.5

I just want the chance to prove 'Money can't buy Happiness'" - a bumper sticker

C. J. Keist                     Email: cjay at engr.colostate.edu
UNIX/Network Manager            Phone: 970-491-0630
Engineering Network Services    Fax:   970-491-5569
College of Engineering, CSU
Ft. Collins, CO 80523-1301

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list