[Samba] - rid is the problem - After update to 2.2.5 'join to domain' doesn't work

Gerald Carter jerry at samba.org
Mon Jul 8 07:09:05 GMT 2002

On Fri, 28 Jun 2002, NSC - NetworkServiceCenter wrote:

> i checked the logfile more carefully and realized, that the ldap-tree
> was searched for the uid of the client and also found. next step the
> tree was searched for a rid, but not the rid i gave the client! it was
> searched for the rid=61002. then i changed the clients rid to 61002 and
> everything worked. after this, i tried a new ws to join to the domain
> and exactly the same scenario occurred. sorry, not exactly - the forced
> rid was now 61004!!(???) with the next ws the forced rid was 61006!
> please, could anyone tell me where these rid's come from???

They are oautomatically generated by smbd from the accout's uid.  
Do not try to set them to any other values.  Things will break if you do.

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

More information about the samba mailing list