[Samba] parsing fix for spoolss & samba-2.2.5

Tom.Klopf at mms.gov Tom.Klopf at mms.gov
Tue Jul 2 11:35:02 GMT 2002

Hey all, I'd like to add to what I saw with this problem.

Apparently, the settings for a shared printer, such as indicating a printer
is "duplex", is being passed to non-privileged clients occasionally.  I
haven't narrowed down the exact conditions that allow for this, but I have
noticed the following:

(Please note that I'm not totally sure of the consistency/replicability of
this - I would use it more as a hint than a rule for the problem)

When using the PCL "unidriver"* for the HP8000, if I change the "Duplex
Unit" option to "Installed" as printer admin, the change does not get
updated to the client.

HOWEVER, if I change another setting at the same time, such as setting how
much ram the printer has, and also change the duplex option, both changes DO
get sent to the client - everything seems to work.

This can only happen once, though. If I do a similar operation, changing the
ram again and setting the duplex option to "not installed", the changes are
NOT passed to the client.

My layman guess for what the problem is: it seems whatever is handling the
options switching is only handling it "some of the time", and mostly when
some other "new" option has been changed to trigger a change on the
non-privileged client.  Additionally, what may seem like an unchanged client
may actually be the client reverting to defaults when something went
wrong...still looking at the problem.

* This is the driver that comes packaged with the Windows 2000 CD. The
driver string is "HP LaserJet Series PCL" (notice that the PCL version is
not given)

P.S. - If it sounds likes I'm obsessing over this problem, it's because we
have about 100 or so HP printers I'm trying to get the driver download
feature to work for, so there :P :).

-----Original Message-----
From: Klopf, Tom [mailto:Tom.Klopf at mms.gov] 
Sent: Monday, July 01, 2002 9:13 AM
To: 'samba at lists.samba.org'
Cc: 'jerry at samba.org'
Subject: RE: [Samba] parsing fix for spoolss & samba-2.2.5

I'm having some trouble with saving printing settings, as well. While the
"printer admin" is free to save settings, such as duplex printing, any
"non-printer admin" user is unable to get these settings from the server.
HOWEVER, if I am a printer admin on another workstation, I'm able to get my
printer settings to the client.  Here's a more detailed description:

1) As a printer admin user, I set my HP8000 printer settings to turn duplex
on (it's a check box in the options), using the "HP LaserJet 8000 Series PCL
6" driver.

2) As a "normal" user, I connect to the printer. As expected, all the
options available to the printer admin, such as switching on and off duplex
printing, are greyed out. HOWEVER, my HP 8000 driver does not have an option
under "printing preferences" for double-sided printing. If I look in the
"Properties", where the "server side" settings for the printer are, the
duplex option is NOT checked (and greyed out, of course, since I'm not the

3) I use unix "nobody" to map all unknown/normal users to. Soo, I say
printer admin = nobody, plus the preexisting users. This makes everyone a
printer admin, right? So...I connect to the printer, and have full control
over it - problem solved. I can "turn on" duplex printing. There's a big
problem with this, though - ANYONE can turn OFF the duplex just as easily as
turning it ON, and since this is set on the server, it applies to
everyone..... can anyone say mucho help-desk calls?

In sum, it seems that the "server-side" settings for printers ARE being
saved (such as options indicating that a printer supports duplex printing),
but they are not being passed to non-privileged clients.  In the case of HP
5si printers, I found that the Mopier driver set got around this, since the
settings indicating that the printer is a duplex printer are stored client
side and set by the client. 

Hope that helps...I'll be happy to do answer questions or do some testing to
help resolve the problem. Thanks very much for looking into this.


-----Original Message-----
From: Gerald (Jerry) Carter [mailto:jerry at samba.org] 
Sent: Thursday, June 27, 2002 12:05 PM
To: SANTOS Alexandre Moutinho
Cc: 'Glen Gibb'; samba at lists.samba.org
Subject: RE: [Samba] parsing fix for spoolss & samba-2.2.5

On Thu, 27 Jun 2002, SANTOS Alexandre Moutinho wrote:

> I have the same problem with a HP 8100DN. I can't use the duplex unit
> from Office, although it is configured in the properties tab (Control
> Panel). I had this working once. It was before I uploaded the driver to
> the server using APW. I added this printer installing a local driver
> (there was no driver uploaded yet) and everything worked well.
> Hope this can bring some light:-)

ok.  I believe you.  I'll take a look at this on Monday.  Bug
me if you haven't heard something by the middle of next week.

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list