[Samba] parsing fix for spoolss & samba-2.2.5

Klopf, Tom Tom.Klopf at mms.gov
Mon Jul 1 07:13:02 GMT 2002

I'm having some trouble with saving printing settings, as well. While the
"printer admin" is free to save settings, such as duplex printing, any
"non-printer admin" user is unable to get these settings from the server.
HOWEVER, if I am a printer admin on another workstation, I'm able to get my
printer settings to the client.  Here's a more detailed description:

1) As a printer admin user, I set my HP8000 printer settings to turn duplex
on (it's a check box in the options), using the "HP LaserJet 8000 Series PCL
6" driver.

2) As a "normal" user, I connect to the printer. As expected, all the
options available to the printer admin, such as switching on and off duplex
printing, are greyed out. HOWEVER, my HP 8000 driver does not have an option
under "printing preferences" for double-sided printing. If I look in the
"Properties", where the "server side" settings for the printer are, the
duplex option is NOT checked (and greyed out, of course, since I'm not the

3) I use unix "nobody" to map all unknown/normal users to. Soo, I say
printer admin = nobody, plus the preexisting users. This makes everyone a
printer admin, right? So...I connect to the printer, and have full control
over it - problem solved. I can "turn on" duplex printing. There's a big
problem with this, though - ANYONE can turn OFF the duplex just as easily as
turning it ON, and since this is set on the server, it applies to
everyone..... can anyone say mucho help-desk calls?

In sum, it seems that the "server-side" settings for printers ARE being
saved (such as options indicating that a printer supports duplex printing),
but they are not being passed to non-privileged clients.  In the case of HP
5si printers, I found that the Mopier driver set got around this, since the
settings indicating that the printer is a duplex printer are stored client
side and set by the client. 

Hope that helps...I'll be happy to do answer questions or do some testing to
help resolve the problem. Thanks very much for looking into this.


-----Original Message-----
From: Gerald (Jerry) Carter [mailto:jerry at samba.org] 
Sent: Thursday, June 27, 2002 12:05 PM
To: SANTOS Alexandre Moutinho
Cc: 'Glen Gibb'; samba at lists.samba.org
Subject: RE: [Samba] parsing fix for spoolss & samba-2.2.5

On Thu, 27 Jun 2002, SANTOS Alexandre Moutinho wrote:

> I have the same problem with a HP 8100DN. I can't use the duplex unit
> from Office, although it is configured in the properties tab (Control
> Panel). I had this working once. It was before I uploaded the driver to
> the server using APW. I added this printer installing a local driver
> (there was no driver uploaded yet) and everything worked well.
> Hope this can bring some light:-)

ok.  I believe you.  I'll take a look at this on Monday.  Bug
me if you haven't heard something by the middle of next week.

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list