[Samba] unix password sync doesn't update smbpasswd file!

Steven J Mackenzie sjm at activenavigation.com
Tue Feb 26 14:32:24 GMT 2002

----- Original Message -----
From: "Mac" <dmccann at nibsc.ac.uk>

> Good. At least it's not a 2.2.3a bug. I take it you have to use
> 'smbpasswd' on the Linux command line?

Yes, I've left it like that ...

> >> Could it be a 'passwd chat' issue?  Mine is currently:-
> >> *new*password %n\n *new*password %n\n *updating*database
> >Mine is
> >*New*password* %n\n *new*password* %n\n *updated*

> Hmmm.  Drat.  No obvious problem with the chat script either then.
> (In my original post I missed the final '*' off the end.  It is there in
> my smb.conf)

There are a few extra *s in my version - they look like they might be
uneccessary, but I remember it taking a few goes to get it set up so that it
worked :(

> P.S. Just out of interest, if a user tried to change password from
> a Linux prompt using ordinary 'passwd' command would that make them
> out-of-sync?

Yes, it does leave things out of sync. I've thought about aliasing passwd to
smbpasswd to stop this happening, but as there hasn't been a problem yet, I
haven't bothered. Most users only use Windows here, and smbpasswd won't work
if the Samba server isn't running, which could be confusing :/

Oddly, I have (once) seen the root smbpasswd get changed without the
unixpasswd staying in sync, and I'm not sure how or why this happened.
Sometimes the PDC (Linux) rejects a new passwd as being bad (too short, or
whatever), but this gets reported to the user as "bad username or old
passwd" on Windows ... ?

More information about the samba mailing list