[Samba] Re: SMB-server from Win2k -> RH 7.2 - Samba 2.2.1a seen in Network Neighbourhood but

Diembo Linux at deschuen.de
Sat Feb 23 01:39:02 GMT 2002

Hi there,
first of all I want to thank everybody who gave me good advise so far ;-). 
Now it's the first time I can give advise, and I'm quite glad that I can 
start giving insted of only taking now :-) !

Hi Petr,
Yes, I have solved my general problems as follows:
First of all you have to check your firewall settings, because that was the 
major problem on my system. On RH 7.2 the netfilter is quite tricky. The 
easiest way I figured out is to read the manpage of ipchains and editing the 
file /etc/sysconfig/ipchains because there are the standard-settings for your 
system. The very easiest way to do this is by making a backup of this file 
first and starting the K-Menu->system->firewall-config (of course as root) 
and setting (at least or even ALL ports) the smb-ports to allow (137-139). 
You do this by putting 137:139 in the corresponding line and you should (only 
for making it work though, you should tighten the rules later again for 
security reasons, because the smb-protocol is a major security hole, you can 
read a lot in the book "Mastering Unix, from Kate Wrighston and Joe Merlino" 
if you are new to the unix-world, it is very easily understandable!) read a 
bit about ipchains and netfilter before or while you're dealing with samba 
(see below). You will also have to check whether the passwords are dealt with 
ON BOTH win2k (or whatever) and your linux-box. I first turned the 
password-encryption off (the reg-file and howto goes with the samba-suite 
itself for win2k). Now, if everything is working fine (again check your 
firewall settings!) you should be able o ping your  linux-box from windows 
with it's hostname (default is linux). If it it still not working consider 
setting up a wins-server on your linux-box (smb.conf: wins support = yes; 
wins server = no #!!!; /usr/local/samba/lib/lmhosts: read the docs for it, 
would be to long to explain every single detail here). Also, if things are 
not working, again check if your samba server can be found by the 
linux-mashine itself by issuing the command: nmblookup linux and nmblookup 
<win2kmashine>. If everything is working you can try setting up encrypted 
passwords on BOTH mashines (read encryption.html NOT encryption.txt because 
you wouldn't find it, it doesn't exist as said in one of the howtos). 
Remember that you will have to make individual smbpasswords (with smbpasswd 
-U <username>; as root). If you have any more problems, don't hasitate to 
ask, but no one is happy with: My smbpasswords don't work. why? as the 
problem-report. ;-)
Also, before you do this all, I recommend installing the new version  
2.2.3a because directories differ in the RH-distro and it seems fine to me 
;-). Just make a backup of your smb.conf file and others if you need them, 
uninstall und compile from source or download one of the rpms.


On Sat, 23 Feb 2002 15:38, you wrote:
> Hi Diembo,
> You wrote:
> > I am new to the list and new to Linux as well as to Samba. I've read
> > quite a few howtos, man-pages and other docs on samba now. I configured
> > my own SMB-server with smbd and nmbd. Of course I generated a smb.conf
> > file and my server is accessible and running on the Linux mashine. I can
> > connect with smbclient to the Linux-mashine and to the win2k-mashine
> > (hostname and service are running). So far, so good. But I cannot connect
> > from the win2k-mashine to the linux-mashine, but I can see it in my
> > Network-Neighbourhood. When I try the command 'net use h: \\linux\public'
> > I get an error-message (on the win2k-mashine, telling me that the host
> > deosn't exist). I tried the same command with 'Linux' insted of 'linux'
> > but it's not written in capitals anyway (only in the
> > network-neighbourhood of win2k). I have encrypted passwords turned on in
> > smb.conf.
> I have exactly same problem here - same version of Linux & Samba
> and same symptoms.
> So I would like to ask You if you find the solution?
> Thanks for response.

Diembo working @ Linux :-P

More information about the samba mailing list