[Samba] reversing domain and user name?

David Edward Shapiro David.Edward.Shapiro at btitele.com
Thu Feb 21 11:48:05 GMT 2002

I don't know why, but I ran make proto in the source directory, ran
autoconf, and then ran configure again with the same options, and then make
worked fine (not sure if I needed the autoconf or the configure again).  I
was able to specify a valid user = INS+DavidSha by the way on the linux
side.  I will try it next with the solaris boxes.  Did the fix for solaris
winbind make it into this cvs?  It's just that it will be hard to remember
to do all these tweaks later, so it would be nice if the cvs took care of


Edit your Makefile so that the line
 WINBIND_NSS_OBJ = nsswitch/winbind_nss.o nsswitch/wb_common.o
 WINBIND_NSS_OBJ = nsswitch/winbind_nss.o nsswitch/wb_common.o

-----Original Message-----
From: David Edward Shapiro [mailto:David.Edward.Shapiro at btitele.com]
Sent: Thursday, February 21, 2002 2:17 PM
To: 'Andrew Bartlett'
Cc: 'samba at lists.samba.org'
Subject: RE: [Samba] reversing domain and user name?

Just go the latest using cvs and ran:

./configure --with-winbind --with-smbmount --with-automount

(I sure would like to run --with-ssl, but nobody answer my questions related
to why it is failing compilation related to util.)

Anyway, make gets the following new errors:

Compiling printing/nt_printing.c
Compiling libsmb/cli_lsarpc.c
Compiling libsmb/cli_spoolss.c
libsmb/cli_spoolss.c:590: conflicting types for `cli_spoolss_getprinter'
include/proto.h:971: previous declaration of `cli_spoolss_getprinter'
libsmb/cli_spoolss.c:669: conflicting types for `cli_spoolss_setprinter'
include/proto.h:979: previous declaration of `cli_spoolss_setprinter'
libsmb/cli_spoolss.c:804: conflicting types for
include/proto.h:992: previous declaration of
libsmb/cli_spoolss.c:883: conflicting types for
include/proto.h:999: previous declaration of
libsmb/cli_spoolss.c:949: conflicting types for
include/proto.h:1005: previous declaration of `cli_spoolss_addprinterdriver'
libsmb/cli_spoolss.c:998: conflicting types for `cli_spoolss_addprinterex'
include/proto.h:1011: previous declaration of `cli_spoolss_addprinterex'
libsmb/cli_spoolss.c:1055: conflicting types for
include/proto.h:1017: previous declaration of
libsmb/cli_spoolss.c:1106: conflicting types for
include/proto.h:1022: previous declaration of
make: *** [libsmb/cli_spoolss.o] Error 1

redhat 7.1

-----Original Message-----
From: Andrew Bartlett [mailto:abartlet at pcug.org.au]
Sent: Wednesday, February 20, 2002 4:39 PM
To: David Edward Shapiro
Cc: 'samba at lists.samba.org'; 'samba-technical at samba.org'
Subject: Re: [Samba] reversing domain and user name?

David Edward Shapiro wrote:
> I can get authentication to work on linux 7.1 with samba 3.0alpha15 if I
> make valid users = @"INS+Domain Users", but if I try to set valid users to
> just a single user:
> valid users = INS+DavidSha, it fails to give me access.  I see the
> in log.winbindd.  It looks like it is looking for a domain called
> DavidSha?!?  My winbindd separator is +.  Can somebody please respond to
> this.
> 2002/02/20 11:37:21, 3] nsswitch/winbindd_sid.c:winbindd_lookupname(76)
>   [27055]: lookupname [DavidSha]\[INS]
> [2002/02/20 11:37:21, 0] nsswitch/winbindd_sid.c:winbindd_lookupname(83)
>   could not find domain entry for domain DavidSha


Thankyou very much, as for reasons beyond explaination, this codepath
didn't get tested when the 'winbind default domain' code went in.

Fixed in CVS.  I'm not sure this solves your original problem however -
could you do some more debugging for me?

Andrew Bartlett

Andrew Bartlett                                 abartlet at pcug.org.au
Manager, Authentication Subsystems, Samba Team  abartlet at samba.org
Student Network Administrator, Hawker College   abartlet at hawkerc.net
http://samba.org     http://build.samba.org     http://hawkerc.net

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list