[Samba] Failure with authentication using Winbind and SMTP

Julio Rojas jrojas at uft.edu.ve
Thu Feb 14 06:52:02 GMT 2002

Hi, my name is Julio Rojas and I've trying to get my Linux (RedHat 7.2) Email Server using Sendmail to use my NT Domain account database. To accomplish this we have tried with Winbind and it has worked for longins at the server and for POP3 authentication, but we haven't been succesful at SMTP authentication. All the emails sent to my Linux server are rejected with the message USER UNKNOWN. The following is an example of my NT server trying to send an email to my Linux server:

SMTP (560) Trying aiur.uft.edu.ve (0)
SMTP (560) Connect aiur.uft.edu.ve [] (2)
SMTP (560) 220 aiur.uft.edu.ve ESMTP Sendmail 8.11.6/8.11.6; Thu, 14 Feb 2002 08:54:12 -0400
SMTP (560) >EHLO uft.edu.ve
SMTP (560) 250-aiur.uft.edu.ve Hello dnselectron.uft.edu.ve [], pleased to meet you
SMTP (560) 250-8BITMIME
SMTP (560) 250-SIZE
SMTP (560) 250-DSN
SMTP (560) 250-ONEX
SMTP (560) 250-ETRN
SMTP (560) 250-XUSR
SMTP (560) 250 HELP
SMTP (560) >MAIL FROM:<jrojas at uft.edu.ve>
SMTP (560) 250 2.1.0 <jrojas at uft.edu.ve>... Sender ok
SMTP (560) >RCPT To:<RED-UFT+jcmr at aiur.uft.edu.ve>
SMTP (560) 550 5.1.1 <RED-UFT+jcmr at aiur.uft.edu.ve>... User unknown
SMTP (560) >QUIT
SMTP (560) 221 2.0.0 aiur.uft.edu.ve closing connection
SMTP (560) Creating message from Postmaster

First of all, is there any way of removing the domain name at the user name (RED-UFT)? And the SMTP server is working fine with local Linux users, it just doesn't work with Winbind.

Here is the PAM configuration file for SMTP. We have made it after the one that works for POP3:

auth       sufficient /lib/security/pam_winbind.so
auth       required /lib/security/pam_pwdb.so use_first_pass shadow nullok
account    required /lib/security/pam_winbind.so

Can you help us??? Thanx in advance...

Julio Rojas
jrojas at uft.edu.ve

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list