[Samba] Problem with [print$]

Frank Fürst ffrank at rz.uni-potsdam.de
Fri Feb 8 11:13:05 GMT 2002

I've got a really strange problem... I tried to set up a [print$] share
(originally in Samba 2.2.1a, now it's 2.2.3) but failed - I don't
remember the exact reason, but I think it was because the printer driver
couldn't be properly installed under Windows with the Add Printer
Wizard. Instead, one had to use an exe-File on the Driver-CD, and that
confused me or the Client or Samba.

Well, this share is just a goody, I might as well cary the driver CD to
all the clients (only about 20). So I disabled the share again by
commenting it out with hashes #.

Strangely, Samba still seems to remember that it once had these printer
drivers: When I install the printer on an NT client, it doesn't prompt
for drivers, and it doesnt download anything, just as if the server was
really an NT server who does the spooling and formatting. I even moved
the directory with the (not-working, partly installed) drivers from
/usr/local/lib/samba/printers to /usr/local/lib/samba/was_printers, and
I restarted Samba several times. In fact, I even rebooted the server:
Still the same behavior.

I thought that the driver information perhaps is associated to the
printer name and set up a second queue for the same printer, with a
different name. And, o wonder, this helped, the client was prompted for
a driver disk. I told this to my colleagues, one took the driver CD and
went to her Client and - booh, it didn't work. This one once had had the
same printer installed locally, so it has the drivers yet, but it sends
only rubbish to the printer queue, as if it expected the "NT server" to
interpret that.

I tried to figure out wether samba thinks it has drivers, but:

~$ rpcclient sugar -U frank
INFO: Debug class all level = 3   (pid 7869 from pid 7869)
Enter Password: 
session setup ok
Domain=[SECKLER] OS=[Unix] Server=[Samba 2.2.3-1 for Debian]
rpcclient $> enumprinters
        description:[sugar\\sugar\hplj6,HP LaserJet 6MP PS,HP Laserjet 6PS]
        comment:[HP Laserjet 6PS]

        description:[sugar\\sugar\Farbnetzdrucker,HP DeskJet 970C Series,Deskjet 970C]
        comment:[Deskjet 970C]

        description:[sugar\\sugar\Farbdrucker,HP DeskJet 970C Series,Deskjet 970C-2]
        comment:[Deskjet 970C-2]


rpcclient $> enumdrivers
rpcclient $>

no drivers anywhere (Farbdrucker and Farbnetzdrucker are the two queues for the
same printer).

Can anybody suggest how I could go on?

Below comes my smb.conf in parts and /etc/printcap

TIA, Frank


domain logons = yes
domain admin group = @wsadmin root
printer admin = @wsadmin

printcap name = /etc/printcap
load printers = yes

path = /var/export/smblogon
guest ok = no
writeable = no

# [print$]
#path = /usr/local/lib/samba/printer
#browseable = yes
#read only = yes
#write list = @wsadmin,root


lp|hplj6|HP Laserjet 6PS:\
Farbnetzdrucker|dj970|Deskjet 970C:\

Farbdrucker|dj970-2|Deskjet 970C-2:\


More information about the samba mailing list