[Samba] Initial setup issues with 2.2.2 on FreeBSD

Martyn Ranyard ranyardm at lineone.net
Thu Feb 7 02:32:04 GMT 2002

It's a gotcha - you are not listening on 127.* because of the interfaces line.

you can probably get a list if you do the following :

smbclient -L ALONZO -I

alter your interfaces line to include 127. and you will be fine and can 
then do -L localhost

At 06:52 PM 2/6/02 -0800, Michael J Horton wrote:
>Howdy All,
>Surprise, surprise, I'm having problems.  I'm sure that it's just some
>stupid little thing that I'm missing, but, as that says, I'm missing it!
>First of all, the environment:
>FreeBSD 4.4-Release
>Samba 2.2.2
>LAN addresses 10.0.0.x, with being my gateway (LinkSys
>router) to the great outdoors.  The BSD server (ALONZO) is on
>And next, the problem:
>When I try to test from my server via smbclient -L alonzo -N, I get
>the message:
>added interface ip= bcast= nmask=
>session request to ALONZO failed (code 0)
>session request to *SMBSERVER failed (code 0)
>If I try to do smbclient -L localhost, I get
>added interface ip= bcast= nmask=
>timeout connecting to
>Connection to localhost failed
>My log.smbd file reads:
>[2002/02/06 17:19:14, 0] lib/util_sock.c:open_socket_in(830)
>[2002/02/06 17:19:14, 0] smbd/oplock.c:init_oplocks(1245)
>   open_oplock_ipc: Failed to get local UDP socket for address 100007f. Error
>  Can't assign requested address
>Paraphrasing from my smb.conf (I took the example they included, and
>modified it for my network)
>hosts allow = 10.0.0. 127.
>security = user
>interfaces =
>dns proxy = no
>    comment = Home Directories
>    browseable = no
>    writable = yes
>    follow symlinks = no
>    comment = Temporary file space - may be deleted at any time!
>    path = /tmp
>    read only = no
>    public = yes
>    comment = common files, excluding drivers and music files
>    path = /usr/common
>I have other shares defined as well.  Most everything else is
>commented out.
>I have tried using SWAT to configure the system, but SWAT doesn't
>think the smbd and nmbd daemons are running.  (According to ps -aux,
>they are pid #s 193 and 195 when started at boot.)
> From my /etc/services file:
>netbios-ns      137/tcp    #NETBIOS Name Service
>netbios-ns      137/udp    #NETBIOS Name Service
>netbios-ssn     139/tcp    #NETBIOS Session Service
>netbios-ssn     139/udp    #NETBIOS Session Service
>And at boot I run a script to start the smbd/nmbd daemons: (and ps
>says that they are running)  I'm not running them from inetd, though I
>tried that first with the same problems.
>/usr/local/samba/bin/smbd -D
>/usr/local/samba/bin/nmbd -D
>I'm usually logged in as root or su when trying this all out, so I
>wouldn't think that it would be a permission issue.  In the hosts
>allow and interfaces entries I have tried adding the localhost ip
>(127.) but with no success there either.  Does anyone else have any
>ideas?  I'd love to be able to share all the files with my home
>Michael J Horton
>Sr Programmer / Owner
>Mad Knight Consulting
>To unsubscribe from this list go to the following URL and read the
>instructions:  http://lists.samba.org/mailman/listinfo/samba


Life's a bitch, but so am I.

More information about the samba mailing list