[Samba] Oplock problems ??

Sanjiv Bawa sbawa at tabmaster.com
Wed Feb 6 09:31:04 GMT 2002

Did you change the kernel oplocks parameter to no?

That seemed to solve a lot of my problems. BUT, you have to make sure that
you are not sharing those files with unix clients or programs.


-----Original Message-----
From: samba-admin at lists.samba.org [mailto:samba-admin at lists.samba.org]On
Behalf Of fibe at post2.tele.dk
Sent: Wednesday, February 06, 2002 10:49 AM
To: samba at lists.samba.org
Subject: [Samba] Oplock problems ??

I am trying to set-up a samba server and have tried with different
distributions and version of Samba but every time when I test it, it fails
with several messages of the following kind:

Feb  5 22:41:02 p200 smbd[2612]:   request_oplock_break: no response
received to oplock break request to pid 2610 on port 1063 for dev = 341,
inode = 98306

The test I do is simply to copy one large file (750 MB) from a Win98 client
to the Samba server and it fails every time.

The situation is the same on all the following configurations:
SuSE 7.2, Samba 2.2.0
Redhat 7.5, Samba 2.2.1
Mandrake 8.1, Samba 2.2.2

I have tried to change the OPLOCK parameters in SMB.CONF and even turn if
off but the fault remains the same. I don't get the above error messages
when OPLOCK is turned off.

Does anybody have any suggestions where to look for the problem ?


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list