[Samba] Printing with CUPS & Samba...

Brad sambauser at capstone.net.au
Tue Dec 31 23:14:00 GMT 2002

I am trying to print from both a Win98 PC via Samba and a Red Hat 8.0
workstation to an HP 4 Plus printer that is connected to a Red Hat 8.0
server. I have managed to get the Win98 PC working OK, but am having
difficulty with the RH8 workstation.

I set the printer up using a browser with <Server>:631, calling it HP4Plus,
and I can send a test print from the browser on the RH8 box via <Server>:631.

I can view and access the other server samba shares OK, but I am unable to 
send it a print job from the RH8 box.

First of all on the RH8 box, I tried to set the printer as a UNIX Printer (lpd
Queue) and named the server IP address and Queue name, but that didn't work. I 
have than told it that the printer is a Windows printer with the following 

The Queue Type=Windows Share Name (HP4Plus)
Username = valid user
Password = valid password
Host Ip - IP address of the server that is connected to the printer
Workgroup = Windows workgroup (workgroup)

I restarted cups, but it still doesn't print, and there are no entries in the
/var/log/cups logs when I am trying to use Samba, but when I nominate the
printer as a UNIX Printer (lpd Queue) I get in the /var/log/cups/access_log:

<server> - - [31/Dec/2002:18:59:37 +1000] "POST / HTTP/1.1" 200 140
<server>- - [31/Dec/2002:18:59:37 +1000] "POST / HTTP/1.1" 200 140
<server>- - [31/Dec/2002:18:59:37 +1000] "POST / HTTP/1.1" 200 80
<server>- - [31/Dec/2002:18:59:37 +1000] "POST /printers/HP4Plus HTTP/1.1" 200 

where <server> is the server that the printer is connected to.

and in the /var/log/cups/error_log:

E [31/Dec/2002:18:59:37 +1000] print_job: Unsupported format

It would seem that printing via Samba would be the best option, but I have not 
been able to get it working with Red Hat 8 and Samba AT ALL.

In the Global part of smb.conf, I have:
load printers = yes
printing = cups
printcap name = cups

and in the shares part of smb.conf, I have:

comment = All Printers
path = /var/spool/samba
browseable = no

comment = Printer Drivers
path = /etc/samba/drivers
browseable = yes

I have tried removing these last 2 entries, but when I do the Win98 PC can't 
see the printer.

I have just about run out of ideas. Can anyone shed any light on this?


More information about the samba mailing list