[Samba] can not connect to the shared printer

naugaranch naugaranch at earthlink.net
Tue Dec 24 12:51:01 GMT 2002

I'm not an expert but I see lots of things missing in your smb.conf file.

You have not defined the samba server netbios name. No samba password path.
Have you set samba passwords?  Define security level.

Also, you may find that you will neeed to stop IPChains and IPTables on the
samba server once you get things running somewhat.  At least until you can
set up firewall rules.

Once you set the netbios name - you should then be able to "see" the samba
server in network neighborhood.  Also, should be alble to ping from windows
both the samba IP address and net bios name.

These are all things I learned over the last few months as I have been
learning Samba - hope it helps.

Tom Winfield


   workgroup = HOME
   netbios name = linux-server
   server string = Tom's Linux Server
   hosts allow = 192.168.0.  127.
   guest ok = yes
   log file = /var/log/samba/%m.log
   log level = 1
   max log size = 100
   security = user
   encrypt passwords = yes
   smb passwd file = /etc/samba/smbpasswd
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   local master = yes
   browsable = yes
   domain master = no
   preferred master = no
   wins support = yes
   dns proxy = no

-----Original Message-----
From: samba-admin at lists.samba.org [mailto:samba-admin at lists.samba.org]On
Behalf Of Xiaodong Zhang
Sent: Monday, December 23, 2002 10:24 AM
To: samba at samba.org
Subject: [Samba] can not connect to the shared printer

Hi there,

I'm learning Samba and I really appreciate somebody out there can help
me out. I'm using RedHat advanced server and a windows 2000. I created a
workgroup on samba and only samba machine and win2k machine are members.
I shared the printer attached to the Linux. From win2k PC, I can see the
workgroup, but I can not find the samba host from the workgroup, nor
does the printer. The smb.conf is attached.

I run smbclient -NL <hostname> and it shows the printer under the Sharename.
If I run net view //<hostname>,  it returns that: "System error 53 has
occured, the network pass was not found"

I setup the samba 2 days ago, and the same problem happened then and
now. BTW, I can mount a windows share from Linux, so I guess samba is

Thanks and merry Christmas.


More information about the samba mailing list