[Samba] can not connect to the shared printer

Xiaodong Zhang zhang at aero.und.edu
Mon Dec 23 16:31:00 GMT 2002

Hi there,

I'm learning Samba and I really appreciate somebody out there can help 
me out. I'm using RedHat advanced server and a windows 2000. I created a 
workgroup on samba and only samba machine and win2k machine are members. 
I shared the printer attached to the Linux. From win2k PC, I can see the 
workgroup, but I can not find the samba host from the workgroup, nor 
does the printer. The smb.conf is attached.

I run smbclient -NL <hostname> and it shows the printer under the Sharename.
If I run net view //<hostname>,  it returns that: "System error 53 has 
occured, the network pass was not found"

I setup the samba 2 days ago, and the same problem happened then and 
now. BTW, I can mount a windows share from Linux, so I guess samba is 

Thanks and merry Christmas.


-------------- next part --------------
# Samba config file created using SWAT
# from localhost.localdomain (
# Date: 2002/12/23 10:01:26

# Global parameters
	workgroup = XGROUP
	server string = Birch Samba Server
	encrypt passwords = Yes
	log file = /var/log/samba/%m.log
	max log size = 500
	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
	dns proxy = No
	printing = lprng

	comment = Home Directories
	valid users = %S
	read only = No
	create mask = 0664
	directory mask = 0775
	browseable = No

	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	browseable = No

	comment = HP Deskjet 940c attached to Birch
	path = /var/spool/samba
	guest account = zhangx
	read only = No
	guest ok = Yes
	printable = Yes
	printer name = hpdeskjet940c
	oplocks = Yes
	share modes = Yes

More information about the samba mailing list