[Samba] Add Workstation to Domain - valid local system user?

Markus Schabel markus.schabel at tgm.ac.at
Fri Dec 20 13:40:01 GMT 2002


I'm running Samba 2.2.7a as Domain Controller, and when I try to add a
workstation to the domain, I get always the following logentry (and the
operation fails):

[2002/12/20 14:30:21, 0] passdb/pdb_ldap.c:pdb_getsampwnam(859)
   LDAP search "(&(uid=vmware-w2ks_)(objectclass=sambaAccount))" 
returned 0 entries.
[2002/12/20 14:30:22, 0] 
   User vmware-w2ks$ does not exist in system password file (usually 
/etc/passwd). Cannot add account without a valid local system user.

[2002/12/20 14:30:23, 0] passdb/pdb_ldap.c:pdb_getsampwnam(859)
   LDAP search "(&(uid=vmware-w2ks_)(objectclass=sambaAccount))" 
returned 0 entries.
[2002/12/20 14:30:23, 0] rpc_server/srv_netlog_nt.c:get_md4pw(176)
   get_md4pw: Workstation vmware-w2ks$: no account in domain

When trying to join the Domain I use the Administrator-Account (in
LDAP). Running the add-user-script as Administrator from the shell works
fine, but it doesn't work from via samba.

In my smb.conf I've tried some settings for domain admin group. I've
domain admin group = Administrator
domain admin group = Administrator @"Domain Admins"
(Administrator is member of the Group Domain Admins). When changing
ownership of a file to Administraot:Domain Admins, it works fine - I can
see the names of the user/group, so NSS-LDAP-Lookups work fine.

I've also tried to change uidNumber and gidNumber of Administrator to 0,
the same problem.

Any ideas what's wrong?

Markus Schabel
| TGM - Die Schule der Technik               |
| IT-Service                                 |
| A-1200 Wien, Wexstrasse 19-23              |
| Tel.: +43(1)33126/316 Fax: +43(1)33126/154 |
| eMail: markus.schabel at tgm.ac.at            |

More information about the samba mailing list