[Samba] Strange behavior with samba mountpoint

Joel Hammer Joel at HammersHome.com
Fri Dec 20 01:07:01 GMT 2002

I have this sort of problem a lot.

I think this happens when there is  network connection
lost. The smbfs mounts don't go away gracefully. In this situation,
when I run mount I often see the share listed as mounted, although I
cannot cd into the mount point. Attempts to umount the share fail, too.

So, what to do? You could reboot. You could try killall smbmount. You could
exit out of the xterm or tty that smbmounted the share. I really don't have
a good way around this. My best results have been obtained by putting a
command to umount all my smbfs connections in my network shutdown script.


On Thu, Dec 19, 2002 at 07:53:40PM -0500, Ted Kaczmarek wrote:
> I have a Redhat 8.0 box with many external connections.
> Several nfs and 3 samba.
> Today I tried to reattach to one on my mounts and I am geting
> "Could not resolve mount point /mnt/dir".
> If I do an ls -a I can see the dir, but when adding the l option to ls
> it does not show up.
> fuser returns for the dir,
> Input/output error
> I apologize if this has nothing to do with Samba, but I am perplexed as
> to how to continue troubleshooting this, and came across the problem
> when doing a mount -t smbfs.
> kernel - 2.4.18-18.8.0smp
> samba 2.2.7-2
> If I create a new directory I am able to mount the NT box on it.
> -- 
> Ted K. <tedkaz-no-at-spam-optonline.net>
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list