[Samba] Winbind and wrong domain

LaSusa, Dan DLasusa at laerdal.com
Mon Dec 16 16:46:00 GMT 2002

Sorry to be a pest....but I worked on trying to figure this out all
weekend....and I'm still at a loss....
Here is all the info collected to date (these are all copy/paste from emails
I sent to the list late last week)
I've been looking thru manpages and online for help.....

I *think* I've got winbind mostly setup (somehow) but it seems to be using
the wrong Domain.

Some info:

I am running RH7.3

Kernel 2.4.18-3

Samba 2.2.7


In my smb.conf file I have:


     security = Domain

     workgroup = LMC

     winbind separator = +

     winbind uid = 10000-20000

     winbind gid = 10000-20000

     winbind enum users = yes

     winbind enum goups = yes

     winbind cache time = 10


In my nsswitch.conf file I have:

passwd: files winbind

shadow: files winbind

group: files winbind


When I do a wbinfo -u or -g I get the info for our LMCMIG domain.


Why is it using the LMCMIG domain instead of what I have in the smb.conf
file? How do I tell it to use LMC??


-------End of 1st email to list---------------

To which Errol responded:

You might want to try the password server parameter. How did you join the
domain? Did you specifiy the IP address of the password server?

------End of Errol's reply--------------

------My Reply-------------------

I joined the domain (LMC) with the following command

Smbpasswd -j LMC -r LMC_EXC1 (this is our PDC) -U administrator

I then got prompted for the password, I entered it

And got the message "Joined the LMC Domain"

Then I stopped and restarted the smb service

Did a wbinfo -u and then -g and still got info for the LMCMIG domain.

I then went into the smb.conf file, changed

Password server = *


Password server = LMC_EXC1

Restarted smb

Still got the info for LMCMIG 

Went back into smb.conf 


Password server = LMC_EXC1


Password server = (IP address of server)

Restarted smb 

Still no luck.

-------end of my reply-------------

-------My follow up email with additional trying-----------------

Following up with more info...

When I run:

./winbindd -i -d 1

winbindd version 2.2.7 started.

Copyright The Samba Team 2000-2001

Added domain LMC (S-1-5-21-1530202311-1617714320-7473742)

getting trusted domain list

Added domain LMCMIG (S-1-5-21-1039822437-107361799-1990678075)

So it looks like it's adding the LMC Domain (which is what I want) but then
adds LMCMIG too (which if fine, but I don't really need) it almost seems to
replace LMC with LMCMIG.

When I then run 

wbinfo -m

all I get is 


I don't get it?!?

--------End of my follow up-----------

So if anyone out there can help....it would be VERY much appreciated....I
just have NO IDEA what could be wrong at this point....



-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list