[Samba] winbind help for newbie

LaSusa, Dan DLasusa at laerdal.com
Sat Dec 14 16:26:00 GMT 2002

Following up with more info...

When I run:

./winbindd -i -d 1
winbindd version 2.2.7 started.
Copyright The Samba Team 2000-2001
Added domain LMC (S-1-5-21-1530202311-1617714320-7473742)
getting trusted domain list
Added domain LMCMIG (S-1-5-21-1039822437-107361799-1990678075)

So it looks like it's adding the LMC Domain (which is what I want) but then
adds LMCMIG too (which if fine, but I don't really need) it almost seems to
replace LMC with LMCMIG.

When I then run 

wbinfo -m

all I get is 


I don't get it?!?


-----Original Message-----
From: LaSusa, Dan [mailto:DLasusa at laerdal.com]
Sent: Friday, December 13, 2002 12:46 PM
To: 'samba at lists.samba.org'
Subject: RE: [Samba] winbind help for newbie

I joined the domain (LMC) with the following command

Smbpasswd -j LMC -r LMC_EXC1 (this is our PDC) -U administrator

I then got prompted for the password, I entered it

And got the message "Joined the LMC Domain"

Then I stopped and restarted the smb service

Did a wbinfo -u and then -g and still got info for the LMCMIG domain.

I then went into the smb.conf file, changed

Password server = *


Password server = LMC_EXC1

Restarted smb

Still got the info for LMCMIG 

Went back into smb.conf 


Password server = LMC_EXC1


Password server = (IP address of server)

Restarted smb 

Still no luck.

Does SMB or Winbind have the info cached somewhere?  Is there a way to flush
that cache???

Thanks for your help!

-----Original Message-----
From: Errol Neal [mailto:eneal at bnbtv.com] 
Sent: Friday, December 13, 2002 12:26 PM
To: LaSusa, Dan
Subject: Re: [Samba] winbind help for newbie

At 11:44 AM 12/13/2002 -0500, you wrote:
>I've been looking thru manpages and online for help.....
>I *think* I've got winbind mostly setup (somehow) but it seems to be 
>using the wrong Domain.
>Some info:
>I am running RH7.3
>Kernel 2.4.18-3
>Samba 2.2.7
>In my smb.conf file I have:
>     security = Domain
>     workgroup = LMC
>     winbind separator = +
>     winbind uid = 10000-20000
>     winbind gid = 10000-20000
>     winbind enum users = yes
>     winbind enum goups = yes
>     winbind cache time = 10
>In my nsswitch.conf file I have:
>passwd:    files winbind
>shadow:    files winbind
>group:       files winbind
>When I do a wbinfo -u  or -g I get the info for our LMCMIG domain.
>Why is it using the LMCMIG domain instead of what I have in the 
>smb.conf file? How do I tell it to use LMC??
>I am a newbie to all of this....
>If I should be looking or asking elsewhere....please just let me 
>Thanks for any help!

You might want to try the password server parameter. How did you join the 
domain? Did you specifiy the IP address of the password server?


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list