[Samba] PDF printing problem - can't find Samba's spool file?

David Brodbeck DavidB at mail.interclean.com
Fri Dec 13 03:08:01 GMT 2002

> -----Original Message-----
> From: Kurt Pfeifle [mailto:kpfeifle at danka.de]

> > Good idea.  I will give this a try after business hours.  
> Right now there's
> > so much traffic on the system that the debug output is 
> overwhelming at level
> > 3.

Okay, I tried this and didn't see anything that (to me) looked like a
smoking gun.  It's definately running my script, and with the options I
expect, but there's no spool file being created.  I don't see any errors
related to printing.  If you want I can post the debug output.

> No, it isn't. If your clients don't run CUPS, you'd have to 
> upgrade them
> to CUPS to reap the fullest of benefits from that approach 
> (PDF backend
> script on the server). If your clients run CUPS anyway, then it is the
> most easy and complete approach. If you don't have any 
> physical printer
> in your net served by CUPS, you can well stick with what you plan.

Right...currently all the clients are just Windows NT machines printing
through SMB.

> Please tell us the content of the smb.conf file (without comments),

        kernel oplocks = false
        workgroup = INTERCLEAN
        security = domain
        server string = Main file server (Samba %v)
        encrypt passwords = true
        name resolve order = lmhosts wins bcast host
        stat cache = false
        winbind uid = 10000-20000
        winbind gid = 10000-20000
        password server = SERVERDELL2200
        winbind separator = +
        create mask = 701
        directory mask = 700
        template homedir = /export/home/%U
        wins server =
        map hidden = yes
        dos filemode = yes
        printer admin = @"INTERCLEAN+Domain Admins"
        path = /export
        browsable = no
        force user = root
        valid users = @"INTERCLEAN+Domain Admins"
        path = /export/spool
        printable = yes
        guest ok = yes
        print command = /usr/local/bin/mkpdf2.pl %s %U %I >>/tmp/pdf.log
        lpq command =
        lprm command =
        path = /export/printers
        browsable = yes
        read only = yes
        write list = @"INTERCLEAN+Domain Admins"
        comment = Output directory for PDF converter.
        path = /export/pdf
        writable = yes
        printable = no
        writable = yes
        printable = no
        browsable = no
        comment = Downloaded files
        path = /export/downloads
        writable = yes
        printable = no
        comment = Information Technology Group
        path = /export/it-group
        writable = yes
        printable = no
        comment = Design and Build Division
        path = /export/engineering
        writable = yes
        printable = no
        comment = AutoCAD xrefs
        path = /export/xrefs
        writable = yes
        printable = no
        comment = Files shared between departments
        path = /export/shared
        writable = yes
        printable = no
        comment = Sales & Marketing Division
        path = /export/sales
        writable = yes
        printable = no
        comment = Financial
        path = /export/financial
        writable = yes
        printable = no
        comment = Human Resources files
        path = /export/hr
        writable = yes
        printable = no
        comment = Management files
        path = /export/management
        writable = yes
        printable = no
        comment = Install CD-ROMs
        path = /export/CDs
        writable = yes
        printable = no
        comment = PLC Programs
        path = "/export/engineering/R&D/Controls/PLC Programs"
        writable = yes
        printable = no

This is such a basic problem that I feel like there must be something stupid
I've done that I'm not seeing, but I'll be damned if I can figure out what
it is.  I've even tried running 'find' against the filename I get from my
debug output to see if maybe the file is just going somewhere weird, but it
never turns up.

> Only if you tell us all your other settings will someone be able to
> guess why your Samba spool directory doesn't seem to get the jobs,
> or why your custom print command isn't executed (questions coming to
> mind are "What's in the [general] section?"; "What's in the [printers]
> section?" etc.)

The custom command *is* executed.  That was one of the first things I
checked.  I know it's being executed because I get debug output from it in
/tmp/pdf.log (note the redirection in the config file above.)  Also, I
confirmed this by looking at the debug level 3 logs.  Right now the only
problem I'm having is the absence of the spool file.  If I can just figure
out where that's going everything else should fall into place.

> Cheers,
> Kurt   [ who was missing a comment about his previous hints 
> and questions
>           regarding the "printing = cups" and "printcap = 
> cups" settings
>           and the question if your smbd is linked against libcups?  ]

Sorry, snipped it by accident.  Samba is *not* linked against libcups.  (I
do *have* libcups, but it's possible I don't have the header files.)

More information about the samba mailing list