[Samba] Has anybody got ACL to work w/ debian, winbindd in a w2k mixed domain?

Jacob Malmberg thundercall1 at hotmail.com
Tue Dec 10 23:06:00 GMT 2002

I dont get the #1-part. Can you please explain a little more in detail what 
you add to sources.list? Also, I dont have /etc/apt/preferences. Can I just 
make one with the contents of the one you pasted here?

And the #3:
I mount /dev/hda1 as /mnt/asd with this line:

mount -t ext2 -o acl -o user_xattr /dev/hda1 /mnt/asd/

setfacl works as a charm on /mnt/asd after that.
However, if I mount the partition with /home/ and /lib/ and all the other 
stuff with the line:
mount -t ext2 -o acl -o user_xattr /dev/hda2 /mnt/hdd/

Then setfacl returns this:
setfacl: directory/file: Operation not supported.
I set the acl by the command setfacl -m u:user:rwx /path. I used to run 
2.4.20 before you mailed me with the same result so I gave your solution a 
shot with the same result. What am I doing wrong? I have all the different 
packages installed...


>From: "Anthony J. Breeds-Taurima" <tony at cantech.net.au>
>To: Jacob Malmberg <thundercall1 at hotmail.com>
>CC: samba at lists.samba.org
>Subject: Re: [Samba] Has anybody got ACL to work w/ debian, winbindd in a 
>w2k mixed domain?
>Date: Tue, 10 Dec 2002 10:07:43 +0800 (WST)
>On Mon, 9 Dec 2002, Jacob Malmberg wrote:
> > Neat. How did you do that, any how-to or something? Im really stuck with
> > this problem. Those sid packages you are talking about, what are those 
> > where do I find them. I hope you help me out on this one as Im really
> > bugged.
>I can tell you roughly what I did.  If you need clarification then don't
>hesitate to ask.
>0) Install woody to your satisfaction.
>1) Modified my /etc/apt/preferences file to:
>    ---
>    Package: *
>    Pin: release l=Debian-Security
>    Pin-Priority: 999
>    Package: *
>    Pin: release a=stable
>    Pin-Priority: 600
>    Package: *
>    Pin: release a=unstable
>    Pin-Priority: 500
>    ---
>    and add the appropriate unstable lines to /etc/apt/sources.list.
>    The only reason I need the unstable lines and the apt preferences is to 
>    the current acl/attr libraries prepackaged.  I don't see that I need to 
>    extra work (especially when a nice DD has done it for me).
>2) follow the instructions at: http://acl.bestbits.at/steps.html
>    for a new install.  I only varied it by using the prepackaged .debs
>    for acl/attr (including the -dev packages).
>3) After booting into the new kernel (in my case 2.4.19, As set there 
>    any patches for 2.4.20) and mounting /home with the "acl" option.
>    I testing {set,get}facl and all was good.
>4) I then build samba from source.   I was doing 2.2.6-pre1 but I've since
>    upgraded to 2.2.7 with no issues.
>5) From there I followed the instructions in "man 8 winbindd" to get the
>    winbind daemon working and join the domain.  I then tested ssh and
>    {set,get}facl with the DOMAIN_user accounts.  Once I had that working
>    (actually there was nothing to do it just worked)  I tried
>    setting/adding/removing ACLS from a win2k box.
>    So far the only problem I've come across is the 8 (of 2000 odd) 
>    don't have a an rid to convert name->sid.  This would be more of a 
>    if the accounts weren't going to be deleted in about 3 days.
>I also have enabled quota support in the kernel and samba and that works
>Yours Tony
>    Jan 22-25 2003           Linux.Conf.AU            http://linux.conf.au/
>		  The Australian Linux Technical Conference!

MSN 8 with e-mail virus protection service: 2 months FREE* 

More information about the samba mailing list