[Samba] weird loop selecting print driver from w2k client w/ samba 2.2.5 w/ patches

daniel.jarboe at custserv.com daniel.jarboe at custserv.com
Thu Aug 29 05:07:01 GMT 2002

Ack, I forgot to say: Kyocera Mita 5530.  The drivers installed on the 
W2K server describe the model as Kyocera Mita KM-5530 KX.  That's what 
it says for my samba server too, only difference is, it works on his W2K 
Server and it doesn't work on my Samba server :(.

On the printer it just says KM 5530.  The drivers came as kx0510a. 
 Online I've also seen references to KM 5530 being FS-9100DN from a 
different website, but I tried the FS-9100DN KX drivers (also in 
kx0510a), and got the same open/close loop problem.

Where can I find the classical drivers?  Can't find anything about them 
on the kyoceramita.com site.


daniel.jarboe at custserv.com wrote:

> Thanks for the tip, I will look into that.  The thing that made me 
> wonder was that it worked fine with w2k print server :\.  I will talk 
> to our print guy though.
> ~ Daniel
> mz at seh.de wrote:
>>On Thursday 29 August 2002 14:19, daniel.jarboe at custserv.com wrote:
>>>After uploading the print drivers from w2k and pressing OK or Apply...
>>>or selecting this printer from the uploaded drivers and pressing OK and
>>>Apply, the printer properties window hourglasses and my machine logs
>>>fill up with the messages below.  The general idea is, it opens the 15
>>>files that were uploaded for the drivers.  Then reopens and closes each
>>>one, then closes them all.  This process is repeated over and over again
>>>while windows print properties shows the hourglass.  I've been able to
>>>upload and use generic windows drivers for other printers just fine, but
>>>when I did this one "from disk" using the manufacturer's OEMSETUP.INF
>>>for this printer (no generic windows driver available), I get this
>>>problem when I press the final OK or Apply.
>>>Trying a test print fails with the error message: " "Test page failed to
>>>print.  Would you like to view the print trouble shooter for assitance?
>>> Operation could not be complet
>>>ed."  First I thought something funky
>>>with winbind was going on because sometimes in the machine log I saw
>>>jarboed, and other times my_dom+jarboed, but turned out open reports it
>>>just as jarboed and close as my_dom+jarboed.  Any ideas out there?
>>>[2002/08/28 11:45:38, 2] smbd/open.c:open_file(233)
>>>  jarboed opened file W32X86/2/KcNtKrnl.dll read=Yes write=No (numopen=1)
>>>This worked fine with w2k print server, and the drivers appeared to
>>>upload fine:
>>>$ ls /usr/local/samba/printers/W32X86/2
>>>KC3D0213.DAT  KCMV3D.INI    KcNtUI.dll   KCPDLXL.DLL   KcRes.dll
>>>KcFSMain.dll  KcNtCore.dll  KCPDL5E.DLL  KcProEpi.dll  KMAGFA1.FDF
>>>KcMV3Da.dll   KcNtKrnl.dll  KCPDLPS.DLL  KcRdrGdi.dll  KMKM5530.MDX
>>>What level of logs would be helpful in better diagnosing the problem?
>>>RH 7.2 (LPRng), winbind, NT PDC, NT WINS server, samba 2.2.5-1 with the
>>>following patches from
>>> Makefile.in.patch       26-Jul-2002 08:18     1k
>>> ldap_start_tls.patch    24-Jun-2002 16:11     1k
>>> samba-2.2.5-printing..> 27-Aug-2002 21:17    30k
>>>Thank you,
>>>~ Daniel
>>Sorry, i got no solution, but would like to know,  what printer and driver you 
>>are using?
>>I found some of the driver names on an Olivetti page, but the list looks to me 
>>like Kyocera KX drivers.
>>I had similar reproducable problems with KX drivers running mad. I daresay, 
>>they are definitly buggy. Still in the case that my guess was right, i would 
>>suggest to try out the classical drivers from Kyocera. These seem to cause no 
>>problems with Samba.

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list