[Samba] directory rights ( again )

Thibault PASTOR pastor at lyon.cemagref.fr
Mon Aug 26 03:03:00 GMT 2002

Hi all,

i've just encountered an unexpected samba's behavior.

I created a shared directory which will contain the drivers for all the
peripherals available on our network. The samba's  entry looks like this :

   path = /home/samba/softs/drivers
   comment = Distribution de drivers
   public = yes
   only guest = yes
   writable = no
   printable = no

then I created 2 subdirectories named 'Imprimantes' and another one named
'Photocopieurs' under the /softs/drivers directory  and I copied inside them
the drivers for some printers to check if everything worked. I set the same
rights ( 755 to both of them ) and the same user/group ( nobody/nobody )

When i tried to install a printer whose drivers are in the imprimantes
folder, it doesn't succeed to copy the files even i give the right path
manually. Although it worked with a printer whose drivers are located in the
photocopieurs drivers.

For information i can copy the drivers files from the imprimantes folder,
it's only when I use the windows 98 'Add printer' function.

maybe it's coming from the inf file, or maybe from somewhere else but i'm
lost right now.

I hope my english was understandable and my problem quite clear.

Thank you

Thibault PASTOR

More information about the samba mailing list