[Samba] NMBD, Roaming Profiles not working after upgrade!!!

Ivan Dimitrov ivan at b4y.co.uk
Sun Aug 25 06:28:00 GMT 2002

Hi everyone ,
Recently upgraded to 2.2.5 on RH73 and
suddenly my Roaming profiles did stop working and on top of this my NMBD is
giving me constant errors!!!!

when i try
nmblookup -U _SAMBA_
name_query fail to find name _Samba_

then i have tried :
nmblookup -B MYSERVER

and then :

nmblookup -U MYSERVER MYSERVER<00>
  looks fine

after this i tried again :

nmblookup -U _SAMBA_
name_query fail to find name _Samba_
  no luck :(

in my conf file i  have

interfaces = eth1 lo     // and this is what i use my eth1
bind interfaces only = yes

when i run  testparm i have not errors!!!!!

My logs are full with messages  :

find_responce_record: response packet id 32345 received with no matching 

and this keep going on and on and on ... at least 5 times per min
i have tried to downgrade to 2.2.3a official RH73 but all my users  can't 
be authenticated!!!
then  i had to upgrade to 2.2.5 again !!!!!

My downloaded RPM is from samba.org However when i
verify it rpm -V  i have

missing /etc/samba/samba.stack
missing /etc/samba/samba.xinetd

I have tried to un install and make clean install of this RPM same problems 

My roaming profiles also stop working and messages i am getting is that 
they can
not be created!!! I have move my profile directory that to different place ....
it was into /export/profiles and now is in /usr/local/profiles
have played with permissions giving full    -R 777  to the entire dir but
  not luck still system can create user profiles
I am using W2K SP2 Clients that can authenticate successfully now but
can't create profiles /this is after the upgrade to 2.2.5/

also the way i have created new profile dir in /usr/local/profiles was

mkdir  -p /usr/local/profiles
chmod 1777 /usr/local/profiles

path = /usr/loca/profiles
read only = no
browesable = yes
create mask  = 0600
directory mask = 0700

Then i have decide to move my profiles dir into /tmp/profiles
because tmp has 777 permissions and i have created profiles in the same way 
i have done
before !!!!
now i can log in and see everything but when i log out i get messages from w2k

"Windows can not update your
roaming profile!! Please contact your
System Administrator"
Details The system can not find the file specified!!! "

1 How can i make my NMBD to work fine !!!!
2 How can i make my Roaming profiles to be ok after the upgrade !!!!

Thanks in advance to anyone taking time to answer this e-mail

and thanks to SAMBA team and Gerald Carter /Samba in 24 hours/ for
wonderfully work and dedication!!!


More information about the samba mailing list