[Samba] Help: Adding printer drivers by RPC fails (NT_STATUS_UNSUCCESSFUL)

Craig Box craig at dubculture.co.nz
Fri Aug 16 18:07:00 GMT 2002

Hi there,

I've had a mighty battle to get printing working with Samba in the last two

Firstly, to get anything working at all (using CUPS), I had to use

disable spoolss = yes
use client driver = yes

Once I finally managed to get the printer (an HP LaserJet Series II) working
with locally installed drivers, I turned my interest to getting it to work
with either Windows drivers stored on the server or the CUPS drivers.  (I
disabled both those options first.)

cupsaddsmb returns me results like this:

Running command: rpcclient jane -N -U'root%secret' -c 'adddriver "Windows NT
Printer Driver hp successfully installed.

Running command: rpcclient jane -N -U'root%secret' -c 'adddriver "Windows

Running command: rpcclient jane -N -U'root%secret' -c 'setdriver hp hp'

rpcclient, when run with a higher debug level, spits me screenfulls of stuff
which I can give someone if necessary.

Then, in rpcclient:
rpcclient $> enumdrivers

[Windows NT x86]
Printer Driver Info 1:
        Driver Name: [hp]

When trying to upload from Windows, we get right to the end and then it
tells me
"Unable to install , Intel, Windows 2000 or XP Driver. Operation could not
be completed."

Now, log.smbd tells me
[2002/08/17 14:49:46, 0]
  move_driver_to_download_area: Unable to rename [W32X86/P] to [W32X86/3/P]

Which is very similar to what I get when trying to use rpcclient:
[2002/08/17 14:51:07, 0]
  move_driver_to_download_area: Unable to rename [WIN40/A] to [WIN40/0/A]

Googling around for this gives some leads from October 2000, but everyone
who has had this problem seems to think that it has worked recently!

The relevant parts of the smb.conf:

        path = /var/spool/samba
        guest ok = yes
        printable = yes
        browseable = no
        public = yes
        read only = yes
        create mask = 0600
        writeable = no

    comment = Printer Drivers
        path = /etc/samba/drivers
        browseable = yes
        guest ok = no
        read only = no
        write list = crb

Though I've tried pretty much anything for those options that I could.
/etc/samba/drivers is owned by crb.

I'm running Debian Unstable's smbd version 2.999+3.0cvs20020723-1.  If you
could offer me any help or suggestions at all, please do so by email.


More information about the samba mailing list