[Samba] samba & acl & xfs

tony tony.n at web.de
Thu Aug 15 11:17:00 GMT 2002

Hi, folks

thank you for your advice, but I'm sorry to report that adding -lattr
did not really help in spite of attr-dev being installed...
Now, maybe it would helo, if I knew WHERE exactly configure is looking
for WHICH files. Where is acl.h supposed to be for example and what
other files need to be present? Or is there a specia XFSed version of
I've tried compiling samba-2.2.4 today with the same effect as

p.s. at Martin.Pienert>> Hey Martin, meinen Glückwunsch, dass Du's
p.s. at Martin.Pienert>> gepackt hast, bei mir funzt es irgendwie also
p.s. at Martin.Pienert>> noch immer nicht...  :-(

>I had the same problem.
>I solved this (XFS+ACL+Samba) problem.
>I add -lattr into configure script.
>Find all "LIBS= -lacl" and replace "LIBS= -lacl $LIBS" by "LIBS= -lacl
>-lattr $LIBS"
>After adding configure writes:
>checking for ACL support... yes
>Using Posix ACLs.
>I don't know why -lattr was removed from configure script. :o(

>>Hi all, again.
>>I am trying to set up samba with acl-support on a debian woody (final) box.
>>The kernel has got XFS-support and getfacl and setfacl are working fine since
>>I have built the acl-debian packages from SGI's acl-sources. Also attr-dev, acl-dev
>>and the appropriate kernel-headers are installed. The acl.h can be found in /usr/include
>>But all my efforts trying to implement xfs are honored by samba with the well known conf
>>  checking for _acl... no
>>  checking for __acl... no
>>  checking for _facl... no
>>  checking for __facl... no
>>  [..]
>>  checking whether to support ACLs... checking for acl_get_file in -lacl... no
>>  checking for ACL support... no
>>I did ldconfig after installing attr-dev and removed config.cache, nothing helped!
>>so, what is wrong here? what am I missing?
>>thx in advance,

More information about the samba mailing list