[Samba] Connection Refuse

Prianggada I Tanaya prianggada.indratanaya at indonesian-aerospace.com
Sat Aug 10 03:44:38 GMT 2002

Dear List,

I hope someone could give me some explanation about above
error/problem I got. 

I have 2 machines, one installed RH7.3 (IP ADDR. =, host name = 
fk0000-msi-srv) and  the other one, Mandrake8.2. (IP ADDR. =
Both machines use Samba 2.2.3a.
At the RH7.3, I got following error if I connect from Mandrake8.2.

$ smbclient -U% -L
added interface ip= bcast= nmask=
error connecting to (Connection refused)
Error connecting to (Connection refused)
Connection to fk0000-msi-srv failed

using nmblookup, send anything ..., found this error.

$ nmblookup -B '*'
querying * on
name_query failed to find name *

either using IP address or server_name give same error above.

Using 'ping' both machine have no problem at all,  either pinging itself or
from other machine. 
If I turn to the documentation 'Using Samba' found at
it says, if nmblookup -B '*' succeeds, but  -B client_ip_address 
fails, there is a hardware problem and ping should have failed.

In my case, ping works fine, but nmblookup failed.
Could any of you have such experience ? 
I've tried to find out to solve the problem but, I think I need some help.

++ pit ++

More information about the samba mailing list