[Samba] 2.2.4-pre - smbclient get NT_STATUS_LOGON_FAILURE

THIBADEAU,DAN (HP-Roseville,ex1) dan_thibadeau at hp.com
Mon Apr 29 05:06:02 GMT 2002

I just downloaded the latest SAMBA_2_2 CVS release (at about 3am PST Monday,
April 29).

I have set it up with "domain" security and joined the Windows domain.  From
other windows machines, and even other samba servers (using 2.2.3a) I'm able
to connect and authenticate just fine.

However, if I execute the following command locally:

	smbclient -L MYSERVER -U dan_thibadeau -W nt_domain

I get the error NT_STATUS_LOGIN_FAILURE.  If I run a backup copy of
"smbclient" from version 2.2.3a on the local machine as above it works fine.

I don't know if it is related, but in the log file (debug 3) I also notice:

	[2002/04/29 04:52:30, 2] lib/util_sock.c:(871)
	  error connecting to (Invalid argument)
	[2002/04/29 04:52:30, 3] lib/util_sock.c:(843)
	  Connecting to at port 139
	[2002/04/29 04:52:30, 0] rpc_client/cli_netlogon.c:(406)
	  cli_net_sam_logon_internal: NT_STATUS_WRONG_PASSWORD

I have full log if needed.  I ran it several times.  I know I didn't type my
password wrong.

Dan Thibadeau

More information about the samba mailing list