[Samba] samba2.2.1a nmbd couldn't be started at suse(7.0) linux (2.2.16) running on s390 platform

dj at 4ict.com dj at 4ict.com
Mon Apr 29 01:22:05 GMT 2002

On Fri, 26 Apr 2002, Li, Lily wrote:

> I'm trying to install samba on suse linux at s390 platform, I tried three
> options, none of them works
> 1) Option1, install samba2.2.1a general release
> I encountered a problem while running /usr/local/samba/bin/nmbd -D, here is
> the log file for you
> /usr/local/samba/var/log.nmbd
> ----------------------------------------------------------------------------
> ---------------------------
> [2002/04/26 09:04:17, 0] nmbd/nmbd_subnetdb.c:create_subnets(242)
>   create_subnets: No local interfaces !
> [2002/04/26 09:04:17, 0] nmbd/nmbd.c:main(835)
>   ERROR: Failed when creating subnet lists. Exiting.
> ----------------------------------------------------------------------------
> ---------------------------
> The system is suse 7.0 linux 2.2.16 on IBM s390 platform, the samba i am
> using is 2.2.1a general release, there is network interface named iucv0, the
> output of ifconfig -a is the follwing
> -------------------------------------------
> iucv0     Link encap:Serial Line IP
>           inet addr:  P-t-P:  Mask:
>           UP POINTOPOINT RUNNING NOARP  MTU:1492  Metric:1  Outfill:1492
> Keepalive:1492
>           RX packets:93067 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:63776 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100
> lo        Link encap:Local Loopback
>           inet addr:  Mask:
>           UP LOOPBACK RUNNING  MTU:3924  Metric:1
>           RX packets:219 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:219 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:0
> -----------------------------------
> 2) I tried also samba1.9.18p1 for mvs, but get an error at make stage
> "collect2: ld returned 1 exit status"
> 3) Use the build-in smb, which is old 2.0.7 version, the smb.conf is
> different from 2.2.1, I could start smbd, nmbd, but couldn't see it from my
> desktop network place. my desktop ip is, netmask, the
> linux host ip is, netmask is, linux is ping'able from
> desktop.

Hello Lily,

I've had simular problems setting up a Samba server. I'm also using SuSE
Linux 7.0 on a Linux/390 system. Only my link to the rest of the network
was thru escon channels.

The problem with me was the configuration of the escon link ip parameters.
Because it is a point-to-point link the netmask defaulted to, which is a broadcast address.  Once I changed that it

But since your ifconfig seems to contains a correct netmaks I'm a bit
stomped. Try asking on the linux-390 maillinglist. You will find more info
about this mialinglist here :


There is also another problem with point-to-point links and Samba. The smb
protocols use network broadcasts a lot. And as you will see as you
compare the ifconfig of a normal ethernet link and a point-to-point link,
you will see that the p-t-p links don't support broadcasts.

So if you intend to run Samba on a mainframe and have a network that
doesn't contains other SMB services like a WINS and PDC, you will need to
run Samba of a image/LPAR that has direct access to a broadcast capable
device (ethernet, tokenring).


Tim Verhoeven
                                Linux & Open Source Specialist
GSM : 0496 / 693 453                          + e-business solutions
Email : dj at 4ict.com                           + consulting
URL : www.sin.khk.be/~dj/                     + Server consolidation

More information about the samba mailing list