[Samba] chmod u+w works for samba server, not for Windows server

Seth Delackner seth at jtan.com
Sat Apr 27 21:55:02 GMT 2002

I have been trying out Samba sharing and hit a snag when on an OS X
client I tried "cvs update" on files that were mounted from a Windows XP
SMB share.

This was because files not checked out are marked attrib +R (read only).
 Try as I might, I could not do "chmod u+w" on those files.

I then tried creating a samba share on a Linux machine running Debian
potato (kernel 2.2.19), with similar results: linux server> chmod u-w
file.txt linux server> ls -l file.txt

OSX client> ls -l file.txt
  rwx...other fake permissions...
OSX client> chmod u+w file.txt
  [same fake permissions as before]
OSX client> vi file.txt
  [write permission gets denied]

I finally tried running a Samba share *FROM* the OS X machine, and to my
amazement, clients can see the correct access permissions AND change
them.  This makes me really happy, but it leaves me bewildered.  What is
going wrong in the other cases?  In the failure cases, I am using the OS
X 10.1.4 built-in mount_smbfs command, with default parameters:

mount_smbfs -W workgroup //user at netbiosname/sharename /mountpoint

Any thoughts?  I am really frustrated at this point, because I thought
it would be impossible to solve this and I thus spent about two days
trying to install AFS (HELL on earth configuring that!) before trying
the successful method I describe above.

More information about the samba mailing list