[Samba] random Win2k unable to log in.

Bruce Carpenter bruce.carpenter at bulletinwireless.com
Tue Apr 23 13:46:02 GMT 2002

Running: SAMBA 2.2.3 on RedHat Linux 7.2 with 2.4.18-rc4 kernel.

SAMBA was running great for over a year for our company up until about 2
weeks ago, then random machines (all win2k) were unable to log in to the
domain.  For a while we thought it was user based but now it seems to
follow the machine rather than the username.  We have roaming profiles
setup and SAMBA as our PDC.

I've tried to find what's causing the machine to have problems but there
seems to be no log when they try to log in.  My log settings are: 

  log level = 2
  log file = /var/log/samba/%m.log
  max log size = 5000

The real confusion is I can log this username on to other machines and
it work, or I can unplug his network card, log him in using the cached
version on his machine, then plug in the network cable again and now he
is able to access all of his shares and printers.  Printers give an
error message saying unable to print, but the job still arrives at the

We've tried removing and readding his smb user and machine, but that
doesn't seem to work either.

Any suggestions or help?  This is a big problem for me as one of the
machines that is unable to login is our company owner, and is
threatening to for a win2k Domain on us if it doesn't get fixed by the
end of the week.


Bruce Carpenter
System Administrator
BulletinWireless Message Systems

More information about the samba mailing list