[Samba] Samba+Ldap - trying to change password

Peter Erickson redlamb at redlamb.net
Mon Apr 22 13:14:03 GMT 2002

On Mon, Apr 22, 2002 at 02:07:57PM -0500, Thomas Klettke said:
> >I have been following the howto for samba and ldap from the idealx.org
> >website, but im having trouble changing the password. Unfortunately, I
> >dont know perl good enough to debug this myself. When I run
> >smbldap-passwd.pl testuser, i get the following output.
> >root at sideswipe% smbldap-passwd.pl testuser
> >Changing password for testuser
> >New password :
> >Retype new password :
> >Change password of an LDAP user
> .
> .
> .
> >Can't return outside a subroutine at /usr/local/sbin/smbldap-passwd.pl
> >line 170, <STDIN> chunk 2.
> >--
> >Peter Erickson
> Peter,
> I've tried to create the same error message, got it when I entered a blank
> password. Is that what you did?
> Another place to check: Did you modify /usr/local/sbin/smbldap_conf.pm to
> match your settings?
> I know, it sounds trivial, but these are the first things to look at before
> attempting any further troubleshooting.
> Thomas Klettke
> thomask at aesbus.com
> Network Administrator
> Aesbus Knowledge Solutions
> Houston, TX 77069
> "The instructions said to use Windows 98 or better, so I installed RedHat."

Thanks for the quick response. I thought that I changed everything that i needed
to in smbldap_conf.pm, but maybe i didnt. I changed the slaveLDAP, masterLDAP,
suffix, binddn, bindpasswd, _userSmbHome, _userProfile, the path to smbpasswd,
and the ldap_path. I thought that was everything. I also ran smbldap-passwd.pl
multiple times and typing in a password and I still havent got it to work. Maybe
its possible that I installed the scripts wrong. I untar'ed it into a directory
and copied all the .pl and .pm scripts into /usr/local/sbin. Then ran make on
mkntpwd and copied that too. Finally I modified smbldap_conf.pm. Any other
ideas? Thanks for the help.
Also, none of the scripts run unless im in the /usr/local/sbin directory. I
think is has to do with the path for packages for perl, but like i said before,
i dont know perl well enough to fix this.

Thanks again.

Peter Erickson
redlamb at redlamb.net

More information about the samba mailing list