[Samba] Samba+Ldap - trying to change password

Thomas Klettke thomask at aesbus.com
Mon Apr 22 12:12:03 GMT 2002

>I have been following the howto for samba and ldap from the idealx.org
>website, but im having trouble changing the password. Unfortunately, I
>dont know perl good enough to debug this myself. When I run
>smbldap-passwd.pl testuser, i get the following output.

>root at sideswipe% smbldap-passwd.pl testuser
>Changing password for testuser
>New password :
>Retype new password :
>Change password of an LDAP user


>Can't return outside a subroutine at /usr/local/sbin/smbldap-passwd.pl
>line 170, <STDIN> chunk 2.

>Peter Erickson

I've tried to create the same error message, got it when I entered a blank
password. Is that what you did?
Another place to check: Did you modify /usr/local/sbin/smbldap_conf.pm to
match your settings?

I know, it sounds trivial, but these are the first things to look at before
attempting any further troubleshooting.

Thomas Klettke
thomask at aesbus.com
Network Administrator
Aesbus Knowledge Solutions
Houston, TX 77069
"The instructions said to use Windows 98 or better, so I installed RedHat."

More information about the samba mailing list