[Samba] Clipper + Samba Locking Failure

Bill Clifford wlclifford at shaw.ca
Sun Apr 21 08:05:02 GMT 2002


      I am having difficulty with Dataflex data files and Samba which
may be in part related to your problem.  Does Clipper/Dbase have
opportunistic locking issues with servers?  Try disabling opportunistic
locking with 



level2 oplocks=no


in your Dbase share (or globally).


      Opportunistic Locking issues are a common problem with various
databases such as Dataflex and Microsoft's own Access.  Since converting
my data to a Samba server I am getting file corruption on a regular
basis (this has never happened on many other sites for many years)
despite turning the oplocks off on the share.  I have just tried making
registry changes on the clients to disable oplocks there and will see
what happens this week.  Any comments on this issue with Oplocks would
be greatly appreciated.


      If this isn't your problem, check which directory Samba is using
for lock files (by looking at the output of testparm) then go to that
directory and ensure that world can read the lock files (read only is
sufficient).  I tested the locking by writing a small program to issue a
lock then went to another workstation to try to save something.  The
save wouldn't occur until I went back to the test program and released
the lock.  I think this means that for Dataflex at least, locking works
as it should with Samba.

            Bill Clifford

            Medical Office Information Systems


Hello Everybody,


I hope someone kan help me with a problem i'm having on several =



We use a clipper (dbase language/Xbase) program for our administration.

Because of the expenses of a novell or a windows server. We decided to =

go for SuSE Linux 7.3 with a Samba server for the windows/dos clients =

(Yes still using good old dos ;) ).

(The novell network worked fine for many years!)


I start recieving a clipper locking failure error:

DBF/NTX 1035

Lock failure


In my samba conf  i've the following options:


kernel oplocks =3D false

strict locking =3D false


Can somebody help me with this problem ?


Greetings Nico Houben



William L. Clifford, M.D., CCFP


-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list