[Samba] Samba configuration issues

Allen Crawford AllenC at mailcode.com
Thu Apr 18 14:02:02 GMT 2002

Ok, I have several questions.  I'll try to be concise.  I'm also very new to
Red Hat Linux and Linux in general, and fairly new to Samba.  I have
configured it successfully on Debian before.

I'm running a fresh install of Red Hat 7.2 right now and did not choose
Samba during setup and selected to disable the firewall.

I have installed the 2.2.3a RPM I downloaded from
<http://va.samba.org/samba/ftp/Binary_Packages/redhat/RPMS/7.2/>  and have
since also tried 2.2.1a, which I've installed from Ximian Red Carpet and the
apt-get program for Red Hat and RPM.  This is the version I'm currently

The first question I have is how come when installing from an RPM it doesn't
set Samba to run at startup automatically?  I read some documentation
somewhere that said it should.  But it didn't on either version for me.

My second question is what is the preferred method of running Samba at
startup on a Red Hat 7.2 box?  The way I did it was added it to the
/etc/rc.local file (/etc/init.d/smb start).

My third question is how do you run Samba from (x)inetd?  In Debian you
simply run "sambaconfig" and it asks you if you want to run it as a daemon
or through inetd.  Is there any preference to running Samba?  It is just for
a small home network, which is behind a Linksys cable/DSL router.  But I was
curious as to if that preference would change if it was in a corporate LAN
environment, behind a strong firewall of course.

My fourth and final question is the one that is really causing me grief.
After getting smbd and nmbd to run at startup, I then used SWAT to configure
my smb.conf file.  Even though I installed from an RPM, it had the incorrect
paths to the passwd program and smbpasswd.  I'm not sure why.  So, my
question is, is the "smb passwd file" parameter asking for the smbpasswd
text file or the actual smbpasswd program?  My /etc/samba/smbpasswd (I'm
using encrypted passwords) file is blank.  So I figured somehow I need to
generate the initial smbpasswd file.  So I tried to run /usr/bin/smbpassword
to see if it would somehow generate my smbpasswd text file.  Here is the
error I get:

[root at paco bin]# smbpasswd allen
New SMB password:
Retype new SMB password:
startsmbfilepwent_internal: unable to open file /usr/bin/smbpasswd. Error
was Text file busy
Cannot open file /usr/bin/smbpasswd. Error was Text file busy
Failed to modify password entry for user allen

In addition, I checked the permissions on some files in my /usr/bin
directory.  Notice the smbpasswd permissions.

Permissions keep changing to:

[allen at paco bin]$ ls smb* -l
-rwxr-xr-x    1 root     root         2678 Aug 13  2001 smbadduser
-rwxr-xr-x    1 root     root       467228 Aug 13  2001 smbclient
-rwxr-xr-x    1 root     root       409532 Aug 13  2001 smbmnt
-rwxr-xr-x    1 root     root       418876 Aug 13  2001 smbmount
-rw-------    1 root     root       701212 Aug 13  2001 smbpasswd
-rwxr-xr-x    1 root     root         2293 Aug 13  2001 smbprint
-rwxr-xr-x    1 root     root       409468 Aug 13  2001 smbspool
-rwxr-xr-x    1 root     root       321980 Aug 13  2001 smbstatus
-rwxr-xr-x    1 root     root         4862 Aug 13  2001 smbtar
-rwxr-xr-x    1 root     root       407804 Aug 13  2001 smbumount

I changed the permissions to match the others and then tried it again with
the same error.  Then, after re-checking the permissions, it reverted back
to what you see above.

Any suggestions?  After typing this email I realized that I think I need to
change the "smb passwd file" parameter to point to /etc/samba/smbpasswd
instead of /usr/bin/smbpasswd.  Oh, I'll include my smb.conf file in my next

Thanks for any help,

More information about the samba mailing list