[Samba] (no subject)

Joel Hammer Joel at HammersHome.com
Sat Apr 13 07:39:02 GMT 2002

> ANY help or direction to additional information would be greatly 
> appreciated

Since you sound at the end of your rope and nobody has responded, I'll put
my two cents in.

It seems as though there is a security package (SSL) kicking in when
you try to access your server. I don't see this with my system, which
suggests that you have either compiled your smbd differently or you have
some directive in smb.conf invoking this security package.

It isn't clear to me if this is really keeping you from your server or not. 

Just some suggestions, in no particular order of importance:
1. Attach the output of smbclient -U% -L localhost
2. Try dropping -U% from your command
3. Try logging onto to one of the shares you see listed:
  smbclient //localhost/share
4. Since security is such a bore, try using a very insecure arrangement at
first and step up to the level of security you need. Here is what I do, and
it works fine for a home network where I trust all my users. (I can still
keep important stuff from being erased/seen by my children/wife via linux
permissions. User ftp doesn't have lots of priviledges.

        interfaces = 
	security = SHARE
	guest account = ftp
	hosts allow = 192.168. 127.0.0.  
	comment = All Files
	path = /
	read only = No 
	guest ok = Yes

On Fri, Apr 12, 2002 at 10:51:42PM -0700, thedrew.net at thedrew.net wrote:
> I was hoping to get a little help but if this is the incorrect forumn then I 
> apologize, please disregard the rest of my message.
> Ok, for starters my webmail client ate my last message, so here I go again. I'm 
> attemping to install a Samba 2.2.1a package onto openbsd 3.0. I downloaded the 
> package from one of the OpenBSD mirrors. After using pkg_add to install samba, 
> I have tried using the default config file as well as editing it. However, when 
> I run smbclient -U% -L localhost which is supposed to list the file shares and 
> server name (I think) I get an error message. SSL: Error error setting CA cert 
> locations: error:00000000:lib(0): func(0):reason(0) followed by a message 
> saying an interface was added followed by a listing of the shares IPC$ and 
> ADMIN$, but no server is listed. (In contrast to the examples I've seen) I also 
> tried smbpasswd -a username to create a user. In all situations, default 
> config, modified config, using a username, I am unable to connect or even get a 
> password prompt from windows 2000 while trying to connect to either the ip or 
> the hostname. Yes, I have tried reading the man pages as well as the How-To on 
> Samba's site. ANY help or direction to additional information would be greatly 
> appreciated. Thank you very much.

More information about the samba mailing list