[Samba] The infamous read_socket_data(478) error

Wayne Sheehan waynes at ostalink.com.au
Fri Apr 12 07:54:02 GMT 2002

> All it's telling you is that the client disconnected. We don't
> know why. We could change the message Samba gives when the
> client does this but it doesn't change the fact it's something
> the client does.
> Jeremy.
> --


I thought the following may interest you.  I have just recently upgraded two
client sites from RH 7.1 running Samba 2.07-36 to RH 7.2 running Samba
2.2.1a-4.  Site A runs an ERP system with some decent sized files, 50+ MB
totalling about 1.2GB.  I have also created some adhoc reports using an ODBC
driver and to my shame Access :)  on a Windows ME client.  Before the
upgrade all was working well.  After the upgrade all appeared to be working
well.  The day to day ERP system has not missed a beat, well not enough to
be noticeable anyway for about two weeks.  Well two days ago I tried to
produce one of the adhoc reports and got the above error.  The Access
database consists of a linked table and some imported tables.  The linked
table still  functions correctly but if I try and import or create a new
link I get the above error.

I have tried a few other workstations Windows ME and Win98 and get the same
error.  I also installed a Netraverse Virtual PC on the Linux Samba server
and it exhibited exactly the same behaviour as the physical PC's???

It is 100% reproducible, if I use the ERP system then the system functions
as it should.  As soon as I try and use Access and the ODBC driver to get at
the ERP data Samba reports the above message and Access complains about the
object no longer being valid (because the Connection is reset of course).
What may also be of interest to you is that when you try and import a file
the driver
 opens a single 20KB~30KB file
containing a flat file listing all the tables in the database (Its a
DataFlex system), this takes a good 70-90 secs, but does eventually display
the list of tables (.dat files on the Samba server) to choose from, of
course the system is dead by this stage.  Prior to the upgrade this was
almost instantaneous.

The client machine config:-
Windows ME, 128MB RAM
Netgear 10/100 MB NIC
Access '97
The database consists of 1 linked and three imported files, its size ~210MB
when populated.

If you would like further information about my configuration then feel free
to email me.  Your thoughts would be appreciated as well as any advice :)

Regards Wayne Sheehan


I have just run another test.  When I import the data I rename the the old
ones till I have the new ones.  If I rename the tables back the Access
database runs like a dream remembering that one of the tables is a link.  I
think this discounts NIC cards/Cables etc as Data and Access Database both
reside on Samba shares.  But if I try and add a new linked table or import a
table things go awry.

More information about the samba mailing list