[Samba] NT MD4 password check failed

Darren Smith Darren.Smith at esd.mun.ca
Fri Apr 12 07:10:04 GMT 2002

Hello All,
  Well, I've admitted defeat.  I've installed Samba 2.2.3a on a Solaris 7
machine and am trying to connect to it from a Win2K SP2 PC.  I am using
encrypted passwords.  The same user (darren) exists on the pc (called
'plm') and the samba server ('sparky2').  The password for this user is
the same on the PC, and the /etc/shadow and /apps/samba/private/smbpasswd
files on sparky2.  I've tried compiling samba with support for shadow
passwords (--with-shadow) but it seems to make no difference.
  When I type 'net view \\sparky2' from the PC, I receive a "System Error
5 has occurred.  Access is denied." message.  Nothing I have tried will
change this.  A partial look at the log.smbd file shows:

2002/04/12 11:15:47, 3] smbd/reply.c:reply_sesssetup_and_X(848)
  Domain=[PLM]  NativeOS=[Windows 2000 2195] NativeLanMan=[Windows 2000
[2002/04/12 11:15:47, 3] smbd/reply.c:reply_sesssetup_and_X(858)
[2002/04/12 11:15:47, 4] lib/substitute.c:automount_server(160)
  Home server: sparky2
[2002/04/12 11:15:47, 4] lib/substitute.c:automount_server(160)
  Home server: sparky2
[2002/04/12 11:15:47, 4] smbd/password.c:smb_password_ok(467)
  smb_password_ok: Checking SMB password for user darren
[2002/04/12 11:15:47, 4] smbd/password.c:smb_password_ok(491)
  smb_password_ok: Checking NT MD4 password
[2002/04/12 11:15:47, 4] smbd/password.c:smb_password_ok(496)
  smb_password_ok: NT MD4 password check failed
[2002/04/12 11:15:47, 4] smbd/password.c:smb_password_ok(510)
  smb_password_ok: Checking LM password
[2002/04/12 11:15:47, 4] smbd/password.c:smb_password_ok(515)
  smb_password_ok: LM password check failed
[2002/04/12 11:15:47, 2] smbd/password.c:pass_check_smb(584)
  pass_check_smb failed - invalid password for user [darren]
[2002/04/12 11:15:47, 2] smbd/reply.c:reply_sesssetup_and_X(962)
  NT Password did not match for user 'darren'!

(I've looked at the DIAGNOSIS.txt file and everything works fine up until
step 8.)

	I cannot see sparky2 in its workgroup in Network Neighbourhood.
When I try "net use x: \\sparky2\darren /user:darren" from the PC, I get
the message "The password or username is invalid for \\sparky2\darren."  I
am asked to re-type the password, but when I do I get "Logon failure:
unknown username or bad password."

	I created the smbpasswd file using mksmbpasswd.sh, then used
smbpasswd to create the necessary password for user 'darren' (the same as
th one I use on the Windows PC).  This is me smb.conf file:

workgroup = workgroup
netbios name = sparky2
hosts allow = ALL
security = User
unix password sync = yes
passwd program = /bin/passwd %u
wins support = yes
guest account = nobody
password level = 5
log level = 4
encrypt passwords = yes
valid users = darren nobody

path = /bigdisk/staff/darren
guest ok = no

	If I set the "security" option to "share", I connect fine.  Things
also work if I set "guest" to "yes".

	I've searched everywhere and tried everything I can think of.  The
answer may be embarrasingly obvious, but I'm just not clueing in.  Any
help would be greatly appreciated.


Darren Smith				   Tel: (709)737-2336
Earth Sciences Department		   Fax: (709)737-2589
Memorial University of Newfoundland	   E-mail: darren at esd.mun.ca
St. John's, Newfoundland
A1B 3X5

More information about the samba mailing list