[Samba] Smb 2.2.2 NT/2k/Root login pblms

No NamePlease faslink at excite.com
Wed Apr 10 07:12:26 GMT 2002

OK: don;t have my smb.conf here BUT:
looked at section 8 of the how to for hints on making Samba PDC.

2 problems:

1) tried entering machinename$/password in password/smbpasssword
CANNOT log into Domain from my W2k Pro (sp2) box.
Also tried using Root with the add script: = 2nd problem.
2) cannot log in as root from w98/w2k system- get pw denied error
even after making pw null.

More info: (1/2) refer to above questions:
1) machine name=newpc, unixid=newpc$ smbpasswd used newpc
1) Cannot log into Samba pdc from w2k box. (user newpc$,pw=newpc)
1) CAN log in as newpc$ from WIN98 box fine (and runs scripts, etc).

2) cannot log in as root from w98 box -- I know it's gotta be a permission somewhere, I get same msg as when bad password on my server. (hints?)--even though I set it for a no password.

on Win2kPro box:
a) set workgroup=workgroup.
a1) logged in to change domain as administrator, entered local nt password.
a2) then entered machinename as newpc, domain=outland
a3) then entered my samba/UNIX id as auth id (also tried root info--also no good here.

get result saying domain could not be found.

More info:

1) machine name does NOT equal domain name 
2) workgroup in smb.conf IS set to outland.
3) netbios name is set to outlandsvr
3) the following is set up in my winnt\system32\drivers\etc\lmhosts file.  servername #Pre #DOM:OUTLAND 

Now I tried everything with and without the lmhosts loaded (loading/deleting via the nbtstat -R (reload and -c) list cache commands)

But I am at a loss.

I have even unsuccessfully to attempt this by using root, and realized that I never used it before, that's when I tried to log into w98 as root and was denied.

ALSO:  According to smbpasswd (5) manual page, the smbpassword file should have a 1 character code for No password/machine account/etc...) this does NOT show up in my smbpasswd file.

Mitch B.
Thanks in advance 


More information about the samba mailing list