[Samba] Error: session request to *SMBSERVER failed (Not listening for ca lling name)

Mack, Daemian DMack at Tickets.com
Wed Apr 3 10:26:03 GMT 2002

I've tried to lock down my Samba shares a bit by specifying hostnames in the
"hosts allow" field.

Fxor some reason, Samba is now refusing *all* connections, even from the
allowed hosts.  For testing purposes, I am using "hosts allow = jetsam".

Here's my smb.conf:

        workgroup = tech
        netbios name = sambaserver
        server string = Samba 2.2.1
        map to guest = Bad Password
        null passwords = Yes
        local master = No
        domain master = False
        wins support = Yes
        guest account = guest
        read only = No
        guest ok = Yes
        hosts allow = jetsam
        encrypt passwords = Yes
        path = /

        path = /tmp/

When connecting with the Windows 98 machine named jetsam, here's what

C:\WINDOWS>net use * \\sambaserver\tmp

Error 51: The specified computer is not receiving requests. Make sure you
specifying the computer name correctly, or try again later when the remote
computer is available.

If I try to connect from the Samba server itself, here's what happens:

# ./smbclient -L sambaserver -n jetsam
added interface ip= bcast= nmask=
session request to SAMBASERVER failed (Not listening for calling name)
session request to *SMBSERVER failed (Not listening for calling name)

I'm not sure what could be causing this.  I've tried stopping and starting
the daemons, but I still get the errors...

Daemian Mack

More information about the samba mailing list