[Samba] samba printer on FreeBSD not accessible to NT

chip.wiegand at simrad.com chip.wiegand at simrad.com
Wed Apr 3 08:38:04 GMT 2002

"Kristyan Osborne" <kris at longhill.brighton-hove.sch.uk> wrote on 
04/02/2002 11:37:13 PM:

> I had a similar problem on win2k, the fix was to install sp2.
> Also make sure the spool directory has the correct permissions for your 
> Cheers
> Kris 

sp2? If you are referring to the NT servic packs, all our NT boxes are at 
I have set up the /var/spool/lpd/ directories as follows -
-rwxr-xr-x bin daemon
I am using the instructions in the book by Ted Mittelstaedt. I've used 
to create several printers - hq (high quality photo), lp (low quality 
photo), text, raw. The raw is, according to the book, for use by Windoze 
to print
to. So, in Windoze NT I create the printer device by doing this:
Add Printer/My Computer/Add Port/LPR Port/New Port/Name of server 
providing LPD -
cwiegand2/Name of printer of print queue on that server - 
I pick the driver from the cd/print test page
This is where I see in the windoze printer window the job and job status 
spooling (for a second or two) then printing - printer error.
I have tried to use all the printer queues that are set up on the bsd box, 
not sure
it I am entering it correctly on the NT box - for the option 'Name of 
printer or
print queue on that server' I have entered only the name - raw (also tried 
lp, etc). 
I have also tried using the path to the queue - /var/spool/lpd/raw, and I 
get the 
same results.
Notice I don't get access denied errors, the spooling appears to start 
then fails.
I also reinstalled sp6a 'just in case', but it still responds with the 
same error.
My printcap looks like this -
# APS1_BEGIN:printer1
# - don't delete start label for apsfilter printer1
# - no other printer defines between BEGIN and END LABEL
# APS1_END - don't delete this
# APS2_BEGIN:printer2
# - don't delete start label for apsfilter printer2
# - no other printer defines between BEGIN and END LABEL
# APS2_END - don't delete this
# APS3_BEGIN:printer3
# - don't delete start label for apsfilter printer3
# - no other printer defines between BEGIN and END LABEL
# APS3_END - don't delete this
# APS4_BEGIN:printer4
# - don't delete start label for apsfilter printer4
# - no other printer defines between BEGIN and END LABEL
# APS4_END - don't delete this

> -------------
> Kristyan Osborne IT Assistant Manager
> Longhill High School
> -----Original Message-----
> From: chip.wiegand at simrad.com [mailto:chip.wiegand at simrad.com]
> Sent: 02 April 2002 17:29
> To: samba at lists.samba.org
> Subject: [Samba] samba printer on FreeBSD not accessible to NT
> I have FreeBSD 4.5 and samba working fine, and a hp 952c, attached via
> parallel
> port on the FreeBSD box, working fine, on the FreeBSD box.
> My smb.conf is set up to share the hp printer, as follows -
> [global]
> workgroup = SIMDOM
> server string = Chip's second PC
> log file = /var/log/log.%m
> max log size = 50
> security = domain
> password server = simrad_1, simrad_2
> encrypt passwords = yes
> socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
> path = /
> wins server =
> null passwords = yes
> remote announce =
> default = Chip's second PC
> dns proxy = no
> protocol = NT1
> netbios name = cwiegand2
> name resolve order = wins lmhosts bcast
> load printers = yes
> printcap = /etc/printcap
> guest account = chip
> print command = lpr -r -P%p %s
> printing = bsd
> [printers]
> comment = HP 952C
> path = /var/spool/samba
> browseable = no
> guest ok = yes
> writeable = no
> printable = yes
> print ok = yes
> public = yes
> Now, I know I don't need all of that stuff, I was just trying everything 
> could to get this to
> work. I used apsfilter to set up the printer initially, and it prints 
> from fbsd apps. When
> I set up NT to print to it I get Access Denied, Unable to Connect when I
> click on the print
> device icon. Do I need to change the permissions somewhere, on the fbsd
> box? (I am
> able to map a drive from the nt box to the fbsd box and copy and write
> files to the bsd box
> from the nt box.)
> --
> Chip Wiegand
> Computer Services
> Simrad, Inc
> www.simrad.com
> chip.wiegand at simrad.com
> "There is no reason anyone would want a computer in their home."
>      --Ken Olson, president, chairman and founder of Digital Equipment
> Corporation, 1977
>  (They why do I have 7? Somebody help me!)
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list