Installing a Samba-Printer on a Windows 2000 Client !??? (BUG ?)

Michels, Gustavo [EES/BR] gustavo.michels at
Thu Sep 20 09:44:03 GMT 2001


I have a couple of 930Cs here and I can tell you they were the worst ones to
configure. I couldn't get a driver that would work and install on the

Well, for a workaround, I have installed it with the 500C or 550C driver.
They'll print, if that is what you want. Of course you won't get 600 dpi
outputs, but they'll print at least.

I'm going to try to install this driver a few more times, if I have any
success I tell you.


-----Original Message-----
From: Klaus Schmidt [mailto:klaschmi at]
Sent: quinta-feira, 20 de setembro de 2001 13:43
To: samba at
Subject: Installing a Samba-Printer on a Windows 2000 Client !??? (BUG?)

Can anyone help me with the following problem? (PLEASE!!)
I am using Samba 2.2 with SuSE Linux 7.2 (Kernel 2.4) and a Windows 2000
It is no problem to see the shared files and printer, which is a HP Deskjet
930C, in the network environment and the windows explorer.
The printer is installed and can be used with linux. It is now supposed to
be used as a network printer with the windows 2000 client.
By double-clicking on the printer (installed as lp-raw), windows tells me
that there has to be a driver installed first and opens a dialog box to
locate the printer's .INF file.
I tried different locations there, all with different versions of a HP
Deskjet 930C driver. The first one is an one year old original from hp. the
second one ist the newest one from the hp homepage. I also tried to use the
driver information from the Windows 2000 CD (Professional AND Server!!)

After confirmig the path to the .INF file, an error box opens with a
message, that the driver is not compatible or not available with the current
version of windows.
(It's the same error box, that appears, when you point to another hardware
.INF file (i.e. a Monitor's .INF file) and therefore contains no printer
That also happens, when I'm using the Windows internal driver

I also tried another driver with linux, but same result...
I also tried to do a completely new windows 2000 software installation
(after format c:), but same result...
I use one of the drivers for the deskjet as a local printer with windows
2000 - with no problems!

Could it possibly be a bug in samba 2.2 software or is it a windows 2000
Can anybody please help me, because I didn't find any adequate information
concerning this problem... 

Thank you, Klaus!

More information about the samba mailing list