Help...Help....WInbind Enum User Problem in Samba 2.2.2

Anthony J. Breeds-Taurima tony at
Wed Oct 31 18:51:07 GMT 2001

On Wed, 31 Oct 2001, ncc22, Gecis (CAP, GECIS) wrote:

> Hi!
> I am facing a very strainge problem. I am not able to do getent passwd and getent group from nt domain. Wbinfo -u and -g options are working fine. But getent is not returning
> domain users and groups.I tried smbclient -L hostname option also its giving me errror ERRsrv badpw. I don't know how to solve this problem. Please Please help me to solve this
> problem. smb.conf , enum user and group optins is yes.
> I am not able to trace the problem.....

Make sure:                                                                      
a) you have joind the domain corrently.                                         
        wbinfo -t  should help there                                            
b) you have something like:                                                     
   winbind cache time = 10                                                      
   winbind enum users = yes                                                     
   winbind enum groups = yes                                                    
   template shell = /bin/bash                                                   
   template homedir = /home/%D/%U                                               
   winbind uid = 10000-20000                                                    
   winbind gid = 10000-20000                                                    
  in smb.conf                                                                   
c) you have tha appropriate domain setting in smb.conf                          
d) your winbindd is running                                                     
e) you have something like:                                                     
    passwd:     files winbind                                                   
    group:      files winbind                                                   
   in /etc/nsswitch.conf                                                        
e) /lib/ exists                                                
g) /lib/ is a symlink to /lib/              
Assuming all that is correct you definatly should be able to see                
domain users with:  wbinfo -u                                                   
domain groups with:  wbinfo -g                                                  
you should be able to "finger DOMAIN\\User" and get info.                       
If you are still having problems the start a new thread and detail exactly      
what is and isn't working.      

Yours Tony.

 * "The significant problems we face cannot be solved at the 
 * same level of thinking we were at when we created them."
 * --Albert Einstein

More information about the samba mailing list