Winbind, RedHat 7.1, Pam 0.74-22 ohh so close to working

Rogelio J. Baucells rogelio at
Wed Oct 24 10:03:41 GMT 2001

Did you change the "template shell" to "bin/bash" or another shell?

If you want to create the home dir on the fly, try this

session     optional      /lib/security/ umask=0077

in your system-auth

It is working for me without any problem in my RH 7.0 and 7.1 boxes

Rogelio J.

-----Original Message-----
From: Adam Ranville [mailto:adam at]
Sent: Wednesday, October 24, 2001 12:45 PM
To: Samba (E-mail)
Subject: RE: Winbind, RedHat 7.1, Pam 0.74-22 ohh so close to working

	Well that seems to have moved me one step closer. I now get a
positive authentication not in /var/messages but it just hangs after I
the password. Missing a home directory? Invalid shell maybe? I checked
logs and I've been getting nothing negative.

Almost there...


tail /var/log/messages:
	Oct 24 12:36:19 hqnis1 pam_winbind[1552]: user 'MKS\adam'


auth      sufficient    /lib/security/
auth        sufficient    /lib/security/ likeauth nullok md5
shadow use_first_pass
auth        required      /lib/security/
account     sufficient    /lib/security/
account     sufficient  /lib/security/
account     required      /lib/security/
password    required      /lib/security/ retry=3
password    sufficient    /lib/security/ nullok use_authtok
password    required      /lib/security/
session     required      /lib/security/
session     required      /lib/security/

-----Original Message-----
From: Anthony J. Breeds-Taurima [mailto:tony at]
Sent: Tuesday, October 23, 2001 10:00 PM
To: Adam Ranville
Cc: Samba (E-mail)
Subject: RE: Winbind, RedHat 7.1, Pam 0.74-22 ohh so close to working

On Tue, 23 Oct 2001, Adam Ranville wrote:

> original file. 

> 	I can access a share without domain\username and it works fine.
Do I
> require domain\(or +) username for telnet? I have tried that as well. 

Yes you will need to login as:
DOMAIN\user   (or DOMAIN+user)
> 	With the attempted system-auth it would kick me out right after
> entering the login. It doesn't even prompt for a password. (single
> me out of it).
> Thanks for the help,
> Adam
> attempted /etc/pam.d/system-auth:


> account     required      /lib/security/
> account     required      /lib/security/

Like Andrew said swap these 2 lines and you should be happy.

Yours Tony.

 * "The significant problems we face cannot be solved at the 
 * same level of thinking we were at when we created them."
 * --Albert Einstein

To unsubscribe from this list go to the following URL and read the

More information about the samba mailing list