Win2K Errors using samba 2.2.2

Mitch McNeel mitchm at
Tue Oct 23 14:57:25 GMT 2001

Thanks for the reply...

        This is pretty close to what we're seeing in our environment.

Our setup:

    1.) Win9x, Win2k machines in the environment with five (5) 2.0.7 and one (1) 2.2.2 samba
servers (in production).
    2.) User's home (Solaris - automount) directories are mapped to (U) drive from a
designated samba server (according to workgroup).
    3.) Netscape profiles live on the user's home directory (U drive).
    4.) Network cards in the machines are 3com-905c and Intel pro 100 with up to date
    5.) Machines are PIII 1 gigahertz, Intel 815 chip set.
    6.) All machine have this ghost connection reg-hack:


* is the above ghost connection reg-hack the correct one that you mentioned.

** Just found out that the error was happening (Win2K ONLY) before upgrade of samba server
from 2.0.7 to 2.2.2 **

After that being said, looks to be a Windows 2000 issue (can neither confirm nor deny).



Ps. I will be upgrading our server to the latest CVS version as requested by Jeremy Allison
tonight.  We'll post update tomorrow.

Thanks to all that replied...

James Nord wrote:

> I have seen this alot with at least the 2.2 series, also I think the 2.0
> series.
> To reproduce this do the following,
> 1)Setup netscape with its profile on the samba server and mapped to a drive
> 2)Start using netscape
> 3)Kill the users smbd process
> 4)use netscape a bit more.
> Windows will reconnect the drive but it refuses to write the data.
> (windows will ghost the connection after 30 minutes of it being unused
> and I always put it down to that)
> It may not be the exact problem you are seeing but results in exactly
> the same error message on the windows side.
> Happens on Mozilla and NS6 to.
> Jeremy Allison wrote:
> >On Tue, Oct 23, 2001 at 10:43:34AM -0700, Mitch McNeel wrote:
> >
> >>I will have to download the latest version and compile it for an install tonight.
> >>Unfortunately this is a production machine, which I can not perform the upgrades during
> >>business hours.  Everything else seems fine (ex: Word, Excel, etc...), as far as I know
> >>(Users haven't complained).  Just seems to be Netscape Communicator 4.x running on Win2K
> >>(ONLY) so far.
> >>
> >>I notice on the page that there is this thing called CVS.  Is this different
> >>from downloading the samba-latest.tar.gz file from the site? If so, then should I being
> >>using this instead of grabbing the latest tar ball?
> >>
> >
> >Yes, this is different. It is the current source code as being worked on.
> >Check out the web page for details. The branch you need
> >to check out is SAMBA_2_2.
> >
> >To get a latest copy use the command :
> >
> >cvs co -rSAMBA_2_2 samba
> >
> >once your CVS environment variables are set correctly.
> >
> >Thanks a *lot*, I appreciate your help on a production
> >machine.
> >
> >Jeremy.
> >
> --
> Technology is a word that describes something that doesn't work yet.
>         Douglas Adams

                        ((~) (~))
                         ( (_) )
                          { ~ }
Mitch McNeel                               # Phone Ext. 2236
Unix Systems Administrator                 # Phone Num. 858-831-2210
Maintenance Warehouse/A Home Depot Company #

More information about the samba mailing list