large files

Ivan Fernandez ivan at
Thu Oct 18 04:21:04 GMT 2001

Hi Again Andrew,

> -----Mensaje original-----
> De: samba-admin at
> [mailto:samba-admin at]En nombre de Andrew V. Samoilov
> Enviado el: jueves, 18 de octubre de 2001 12:26
> Para: ivan at
> CC: samba at
> Asunto: Re: large files
> I meant libc6 and 2.2.4 must be fine.  Can you create 22 GB files from
> root by something like ?
> dd if=/dev/zero bs=1024k count=22528 | tr '\000' 1 > filename

yes, it worked fine, this is what iI got:

pokeball:/backup1# ls -l test
-rw-r--r--    1 root     root     23622320128 Oct 18 12:55 test

> If you can, it may be non-root user limitation. Try ulimit -a in your
> bash from that user.

... and this is what ulimit -a returns as I run it from the backup user:

admin at pokeball:/backup1$ ulimit -a
core file size (blocks)     0
data seg size (kbytes)      unlimited
file size (blocks)          unlimited
max locked memory (kbytes)  unlimited
max memory size (kbytes)    unlimited
open files                  1024
pipe size (512 bytes)       8
stack size (kbytes)         8192
cpu time (seconds)          unlimited
max user processes          4095
virtual memory (kbytes)     unlimited

> Well I test it on my ext2/2.2.19/glibc2.1.3 system and I really can't
> create more than 2 GB long file.
> Now I have not access to system 2.4.x/glibc2.2.4 system.

This is normal in ext2. File size is limited to 2 Gb. I have read some
messages saying this limitation is not in ext2 natively, but I think all
ext2fss from all major distributions I've been working with have this

> > By the way, previous to mc 4.5.55 installation I had to download and
> > install libstdc++2.10-glibc2.2_2.95.4-0.011006_i386.deb...
> perhaps it
> > interferes in all this?
> >
> mc and libstdc can't be  reason for samba problems.
> Regards,
> Andrew.

Thank you Andrew.
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list