smbclient test fails (Bad Password Error)

Mark Jervis Sr. mjervis at
Mon Oct 15 11:18:02 GMT 2001


I have installed Samba 2.2.2 on a debian linux machine running debian 2.2
r3. I have been watching the usergroup and and have been reading the Using
Samba HTML pages. 

Here is a copy of my smb.conf:

# Global parameters
        workgroup = JERVIS
        interfaces =
        bind interfaces only = Yes
        security = SHARE
        log file = /var/log/samba/log.%m
        max log size = 1000
        read bmpx = no
        time server = yes
        socket options = TCP_NODELAY
        os level = 65
        preferred master = Yes
        dns proxy = No
        guest account = smbuser
        hide dot files = no

        comment = mjervis
        path = /home/mjervis
        read only = no
        create mask = 0664
        directory mask = 0775
        guest ok = yes 

And when I run testparm I get:

htmlplace:/etc/samba# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[public]"
Processing section "[web]"
Loaded services file OK.
Press enter to see a dump of your service definitions

Then I run smbstaus and I recieve:

htmlplace:/etc/samba# smbstatus

Samba version 2.2.2
Service      uid      gid      pid     machine

No locked files

Share mode memory usage (bytes):
   1048464(99%) free + 56(0%) used + 56(0%) overhead = 1048576(100%) total

But when I run smbclient (password I hit enter):

htmlplace:/etc/samba# smbclient -L localhost
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
Domain=[JERVIS] OS=[Unix] Server=[Samba 2.2.2]
tree connect failed: ERRSRV - ERRbadpw (Bad password - name/password pair
in a T
ree Connect or Session Setup are invalid.)

Can someone shed some light on what I'm doing wrong? I also cannot see the
samba shares or even the computer from my win98 machine in network

Thanks in advance for any enlightenment,

Mark Jervis

More information about the samba mailing list